Invalid AuthID for onedrive

Generated AuthID for OneDrive always rejected as invalid. I’m on W10 trying Duplicati “Path” is given simply as the name of an existing folder on OneDrive.
I don’t know what to try next?

Hi, @peteg, welcome to the forum!

I have a few questions to hopefully help us figure out what’s going on:

  1. Can you post the actual error message from the Duplicati log?
  2. Is this a new backup or on that previously worked then suddenly stopped working?
  3. Is this OneDrive personal or business?
  4. Did you follow the procedure shown here?
  1. Dec 3, 2017 11:21 AM: Request for http://localhost:8200/api/v1/remoteoperation/test gave error
    Dec 3, 2017 11:21 AM: Reporting error gave error
    Dec 2, 2017 1:14 PM: Request for http://localhost:8200/api/v1/remoteoperation/test gave error
    After test connection:
    Failed to connect: Failed to authorize using the OAuth service: Invalid authid in query. If the problem persists, try generating a new authid token from: Duplicati OAuth Handler
  2. personal
  3. follow procedure: yes (but login not requested, but returned cryptic string anyway)
    Login not requested whether I am already logged-in or not.
    Thanks for looking into my case.

Just checking. Has there been any progress on this?

If you click on the error from the error log it should give you details.

For example, if I abort a backup I get the following “Error in worker” entry in my log, and if I click on it I can see the “System.Threadying.ThreadAbortException” details.

Dec 8, 2017 3:56 PM: Error in worker
System.Threading.ThreadAbortException: Thread was being aborted.
   at Duplicati.Server.Runner.Run(IRunnerData data, Boolean fromQueue)
   at Duplicati.Library.Utility.WorkerThread`1.Runner()

I haven’t seen any other recently reported issues with personal OneDrive connections so at the moment I’m assuming the issue is something specific to you.

It really feels like something went wrong with setting up the AuthID so I’d recommend trying it again (you may first need to log into the OneDrive consent management page and delete the existing consent, I’m not sure).

I deleted the existing consent and tried again but got the same error message.
From the log:
Dec 9, 2017 11:10 AM: Request for http://localhost:8200/api/v1/remoteoperation/test gave error.

Duplicati.Library.Interface.UserInformationException: Failed to authorize using the OAuth service: Invalid authid in query. If the problem persists, try generating a new authid token from: ---> System.Net.WebException: The remote server returned an error: (400) Bad Request.
   at Duplicati.Library.Utility.AsyncHttpRequest.AsyncWrapper.GetResponseOrStream()
   at Duplicati.Library.Utility.AsyncHttpRequest.GetResponse()
   at Duplicati.Library.JSONWebHelper.GetResponse(AsyncHttpRequest req, Object requestdata)
   at Duplicati.Library.JSONWebHelper.ReadJSONResponse[T](AsyncHttpRequest req, Object requestdata)
   at Duplicati.Library.OAuthHelper.GetTokenResponse[T]()
   at Duplicati.Library.OAuthHelper.get_AccessToken()

   --- End of inner exception stack trace ---
   at Duplicati.Library.OAuthHelper.get_AccessToken()
   at Duplicati.Library.Backend.OneDrive.FindFolder(String folder, String parentfolder)
   at Duplicati.Library.Backend.OneDrive.FindFolders(Boolean autocreate)
   at Duplicati.Library.Backend.OneDrive.List()
   at Duplicati.Server.WebServer.RESTMethods.RemoteOperation.TestConnection(String url, RequestInfo info)
   at Duplicati.Server.WebServer.RESTHandler.DoProcess(RequestInfo info, String method, String module, String key)

Hope this helps

Success! :grinning: I’m not sure why though I did clear the ID field before pasting the Auth string.
Thanks for your helpful guidance.

Yay! Thank YOU for the patience to try different things!

I hope you don’t mind but I went ahead and edited your post by putting “~~~” before and after the error message to make it easier for others to read - and then I flagged it as the Solution in case somebody else runs into a similar issue.