Install issues on Raspberry PI 4

Hi, I’m installing Duplicati on a Raspberry Pi4 with 4GB and a 0.5T SSD using docker.
It all seems to run just fine.

    image: duplicati/duplicati
    container_name: duplicati
      - PUID=1000
      - PGID=1000
      - TZ=Europe/Amsterdam
      - CLI_ARGS= #optional
      - /opt/duplicati/config:/config
      - /opt:/source
      - 8200:8200
    restart: unless-stopped

But if I look in the log of portainer. There is nothing. It says it is running.
The config directory is created, but completely empty. Probably something silly.

– Paul

Hi PaulUitWijchen

Welcome to the forum!

Have you tried pointing your web browser to port 8200? I don’t remember if anything goes into the config directory until you’ve actually configured something in Duplicati, or not. In any case, try out port 8200 and see what you see.


Hi Lerrissirrel,

First of all, if I check if there is a process running called duplicati: I do indeed see some processes:

paul.vanadrichem@raspberrypi:~ $ ps -ef | grep duplicati 13134 13009  0 19:00 pts/0    00:00:00 grep --color=auto duplicati
root     28836 28765  0 Mar23 ?        00:00:05 /usr/sbin/tini -- /usr/bin/duplicati-server --webservice-port=8200 --webservice-interface=any
root     29083 28836  0 Mar23 ?        00:00:01 DuplicatiServer /opt/duplicati/Duplicati.Server.exe --webservice-port=8200 --webservice-interface=any
root     29185 29083  0 Mar23 ?        00:00:19 /usr/bin/mono-sgen /opt/duplicati/Duplicati.Server.exe --webservice-port=8200 --webservice-interface=any

But if I try to connect using the browser to port 8200. I only see a single line:

The host header sent by the client is not allowed

Any ideas?

Duplicati has a setting as to which hosts are allowed to access the web ui. It defaults to only allowing the local host.

One option is, if you can run a web browser from server on which you’re running docker, you can see if you can access port 8200 that way. If you can, then you can modify which hosts are allowed access via the web gui itself (in the settings).

Alternately, you can modify the start of duplicati itself to use the “–webservice-allowed-hostnames=*” option on the command line (The * means all hosts, you could specify a specific IP address or host name here). I’m not exactly sure where that can be done. I’m no expert with docker, but it does seem that you might be able to do it via your container config with the “CLI_ARGS= #optional” setting.

Hi Lerrissirrel,

Indeed that was the issue. I opened a VNC session on the PI and then on the PI (in VNC) I opened a the Chrome Web browser and then I was able to log in. THen I could set the passwd and the set this * to allow all hosts to access. I later set entered the hostnames to narrow it down.

Thanks for your help.

– Paul