Imported Backup Job to create new Job, now the Job schedules are mixed


#1

Basically whatever I schedule Job 1 to do, it will apply schedule to Job 2. (while Job 1 ignores the new schedule)
If I change schedule on Job 2, it will apply that schedule to Job 1. (Job 2 ignores new schedule)

I exported Job 1 to save time (by bringing over s3 settings) and imported that export to create Job 2. Modified name, source and schedule before running Job 2.

Seems like the schedules have the Job Ids mixed. Is there a way to fix this?

Thanks,
Just started using duplicati, thanks for the hard work put into this software.


#2

Hi @pcaid, welcome to the forum!

I only recall hearing of one other person reporting this kind of issue and I think in their case it turned out to be confusion between tray and service instances of Duplicati.

Which version of Duplicati are you running, on what OS, and how (tray icon vs. service/daemon)?


#3

2.0.3.3, Windows 7 PRO 64bit, Tray Icon.

Thanks


#4

Are you using only one user or are multiple logins using Duplicati? It shouldn’t matter as they normally each store settings on their respective user folders, but it’s possible to override that with settings so maybe there’s a big in that process…


#5

Just using on one user.

I exported both jobs to see info and the export has the first job as ID 1 and the second job as ID 2, plus the schedule in the exports are correct. I was expecting the IDs or the schedules to be mixed.


#6

I’m sorry this got lost in the shuffle - did you find a workaround for this?

If not, I’m curious what happens if you change the schedule of job 1 then export both jobs “As Commandline”. Does the updated schedule appear on the correct export?

I’m trying to narrow down if the issue is related to the GUI somehow getting things crossed when saving / loading job info or the scheduler getting confused.

(And yes, it sounds like you already checked this with the export to file test but this one uses a slightly different chunk of code.)