I just cannot set up my Google Shared Drive by the Duplicati built-in tool.. Please Help!

(Earlier: bein’ unable to set up this connection earlier I’ve just used Raidrive to emulate target dtorage. But Raidrive stopped its free upload service to the shares google disk. So, I’ve got to set up this connection).

There are 2 ways to make it work:

  1. Using the google drive client. It sets the LOCAL drive with its own letter so I supposed it will work easily (no it didn’t)
  2. Using the built-in Duplicati tool

The result is:

  1. Of course, I need the backup bein’ saved in the cloud storage ONLY, not at my PC, so the backup folder in the Google Drive client is set to “cloud only”. And this way doesn’t work due to the Duplicati’s strange manneer to write the whole backup into c:\Program Files\Duplicati 2\gmail\ directory (in my case) without (before) any sign of upload. My TMP and TEMP system folders are set to drive D: and Duplicati “sees” that when I open additional parameter “tempdir”. I tried to switch the syncronous upload on but this also did’t give any result.
    So, when I try to backup my 134GB .vhd to the gdrive Duplicati just reports “lack of free space” after the C: dick is full and that’s all.

  2. When trying to connect to the shared drive using its link obtained via web interface RMB menu, Duplicati asks for AuthID. Limited or Full access AuthID may I insert – doesn’t matter: Duplicati just returns the same request after the connetction re-try. I also tried to switch to the 2-factor ID but with the same result.

The question is: is there a user’s manual or “howto”? Or maybe somebody just could write how EXACTLY one can connect to the google shared drive? Both ways are welcome.

Thank you for reading this :slight_smile:

Duplicati User’s Manual exists, for general info. For specifics, sometimes you can use forum search tool.

How do I use Google Team Drive as backup location? might apply. I have no Google Shared Drive myself.

That’s an odd path. Is there a gmail anywhere in your configuration? One way that things sometimes get under there is if someone uses a relative path, e.g. starts talking about a gmail folder not starting from C:, but it may require Destination screen 2 Storage type dropdown at Local Folder or drive to get it.

RMB is right mouse button? Used where? You would normally left click the AuthID link to populate AuthID, using the Google Drive (limited) login, and never being asked about (or seeing) full access (which may go away courtesy of Google discontinuing it). A Shared Drive (formerly Team Drive) needs some more setup in Advanced options for googledrive-teamdrive-id, as in the link cited above. That might be what you want.

Thanks a lot for your reply. I’ll try again to solve that issue in short days. And I will follow your advices carefully. In case of success I’ll post the report here.

Hi Serge,

did you reach to solve the problem?. I’m stuck in the same isssue and team drive solution doesn’t work.


No, I didn’t. Tried right after getting the answer above with no result and just embodied another scheme of backing up data with another cloud services which can be reached by WebDAV or mounted easily like disks.