I have never received an email

I put:

> --send-mail-from=alerts@domain.com
> --send-mail-level=Warning,Error,Fatal
> --send-mail-password=xxx
> --send-mail-subject=Duplicati %OPERATIONNAME% report for %backup-name%: %PARSEDRESULT%
> --send-mail-to=myemail@domain.com
> --send-mail-url=smtps://smtp.gmail.com:465
> --send-mail-username=xxx
> ```
I put the same thing as on my thunderbird smtp that works, there is in the thunderbird settings: OAuth2
Is this what can be a problem and if so, how to put it on?

I was unable to duplicate this. Could you could show us the log output when this happens?

About --> Show Log --> Live --> Information

It will appear like this:

I was able to send emailed reports from Duplicati using both SMTPS on port 465 and SMTP with STARTLS on port 587 using a gmail.com account.

Also, one other thing is that in the settings you have provided you have configured Duplicati not to send emails unless there is an error with the backup job in the “send-mail-level” setting. Are you experiencing errors for which you are expecting to get an email?

Yes I put this in the general duplicate settings.
I have several backups that work well and one backup that does not work

10 déc. 2020 16:39: Échec de l’envoi du message: MailKit.Security.AuthenticationException: 535: 5.7.8 Username and Password not accepted. Learn more at 5.7.8 https://support.google.com/mail/?p=BadCredentials 20sm9555000wmk.16 - gsmtp --> MailKit.Net.Smtp.SmtpCommandException: 5.7.8 Username and Password not accepted. Learn more at 5.7.8 https://support.google.com/mail/?p=BadCredentials 20sm9555000wmk.16 - gsmtp

Does the one backup job that doesn’t send mail have any mail settings set on it that are different from the ones that are set in the General settings? If it does, the settings on the specific job will override the ones in the General settings:

The log message you included indicates that the message was not sent due to the username and/or password not being correct. I can’t think of another reason why some jobs would work and others would not unless the specific job had different settings on it.

Strange, the username and password works correctly online.
I put this parameter only in those of duplicate not in a backup parameter.

With gmail or gmx it doesn’t work any more.
Doesn’t anyone else have the same problem?
other ideas?
I’m on ubuntu 20.04

Apps have different security rules than web access (if that’s what you mean).

Did you read at https://support.google.com/mail/?p=BadCredentials
Less secure apps & your Google Account might apply. If not, try the others…

For me, only if I don’t allow less secure apps. Otherwise works both ways like:

Please clarify where you are putting parameters. If not on backup, try there.

OP syntax looks like command line options. What command, on what OS?

Do you run GUI too? If so, how does that work? It avoids CLI quoting issues.

Thank you for being there often to help :slight_smile:

I put the following commands in the general parameters and it works :slight_smile:
–send-mail-subject=Duplicati %OPERATIONNAME% report for %backup-name%: %PARSEDRESULT%

If one day someone understands and solves the problem with gmail, I’ll be a taker because I followed the various comments I understood, without success.

I use the graphical interface under firefox last version with ubunut 20.04
I don’t know what CLI is !

This doesn’t say much about what was actually attempted, so to pick on one specific thing to confirm:

Is https://myaccount.google.com/lesssecureapps set to this?


Changing to that will probably produce some alert to your gmail, smartphone, etc. to warn you about it.
I’m not clear on your thunderbird result. Did you say it worked with same settings? OAuth2 is different.

How to add Gmail SMTP in Thunderbird describes some steps that you may or may not have followed, however if you followed them, then I think you got OAuth2 authentication which Duplicati email can’t do.