How to make sure Duplicati starts/runs schedules on Linux?

I love Duplicati but I believe I’m not doing things quite right. I’m on Xubuntu 20.04 and manual backup seems to work fine, but after I restart the computer Duplicati does not run the scheduled backups… I must be missing something.

What does the main status bar at the top say? It should say “Next scheduled task…” like this (assuming it’s not currently running a job):

Also, is this a desktop/laptop or a server? If server and you want Duplicati to run without anyone being logged in, you need to enable it to run as a service (via systemctl).

Hi! Thanks @drwtsn32,

It is a personal laptop. Everything local. I just want to make sure it is running after log in.

Right now it says: Next scheduled task: home Tomorrow at 13:00
but I had to launch Duplicati and there is a tray icon now, it seems like there is no tray icon after restart. Makes any sense?

Gotcha! Yes, you need to add Duplicati as a startup application. I’m not sure how to do that with Xfce. I found this but am not sure if it still applies to Xubuntu 20.04.

1 Like

Perfect! That was the missing piece. Thank you very much!