How to install Duplicati on Synology / DSM

Disclaimer: I don’t have a Synology box so can’t do much with these instructions, but I’m hoping creating this WIKI post (use the edit button below) will prompt others who HAVE installed Duplicati on a Synology box to flesh out these instructions. :slight_smile:

This initial skeleton is based on @Wim_Jansen’s How to install Duplicati on Synology post, @Kareltje1980’s Synology installation post, and might eventually lovingly borrow @drwtsn32’s image from How to install Duplicati on Synology. :wink:


  1. First install mono (it’s under the beta applications IIRC)
  2. Download Duplicati (from Duplicati) and manually install by uploading it via the package manager.
  3. Make sure your user is part of the http group (or you may get “Connection to the server is lost” messages)
  4. You can run it via the web interface of Synology. If you want to run it outside of the web-interface, I think you will have to start it manually.

    Note: Don’t access duplicati using the service, but login using the local IP:5000 for some reason it crashes then.





Synology Device status:



1 Like

Thanks! :+1:

I’ve updated the post but if you have a sec could you try using the Edit button near the bottom of the initial post to and see if you’re allowed to edit it directly?

I tried to set it up to allow that but may have done something incorrectly… :slight_smile:

Thanks for confirming it!

That only works for posts that are set up to be a “wiki”, which is what I try to do for my #howto items since they are mostly just gathering other people’s input in one place anyway. :wink:

I tried on a synology DS918+ and works correctly.

Edit worked for me… I added 1517+ to the confirmed working list.


Previosly, I commented that works correctly on DS918+. Now I tried too on DS213j, and on the two models I can to install it and the backup task works correctly.

But I detected that when you restore a backup, if your path contain spaces, doesn’t list it’s subfolders. You get an error the bad request: Invalid HTTP version in Request Line GET.

You can tried on an others synologys? The same version of duplicati on Windows or Qnap, works correctly if the path contain spaces.

On github (issue#2837) this error has reported, but no exist the fix?


Thanks for letting us know about the DS213j install!

I don’t have a Synology myself so can’t test restoring for a path that contains spaces - hopefully somebody else with one can try it out.

Would be nice to edit the OP to include the possible restore bug on the DS918+ too (actually it’s only indicated in the DS213j)

I didn’t realize the restore issue happened on both devices, thanks for clarifying.

The OP is a Wiki so you should be able edit it yourself using the image button in the bottom right corner under the post.

Please let me know if you can’t as that means I’ve set something up wrongly. :slight_smile:

Oh I didn’t know, just done it :+1:


Sorry for not asking earlier (or missing it if already provided) but what versions of Duplicati and DSM are you using?

II tried with and The same problems whith the two versions.

Thanks - how about the Synology DSM version? Maybe there’s something in a version of that that doesn’t play well with Duplicati.

For de DS213j I don’t remember the first version of test, but I updated to the last (6.2.1-23824-2) and I get the same issue.

For DS918+ with versions 6.1.7-15284 and 6.2.1-23824-2 too.


I tested the latest release ( beta) on a DS211j and a DS218+.

For the DS211j I found that Duplicati didn’t work reliably. Roughly half of the connection attempts with B2 cloud storage failed due to HTTP errors. When a connection did work, starting a backup run already took minutes – that was before the first file started transferring. Lack of space on /tmp further complicated matters. The latter problem could likely have been resolved with some effort. The former couldn’t. I concluded that the DS211j is likely too slow to run Mono/Duplicati.

My attempt with the DS218+ fared much better. Installation was smooth, and I had the first backup running with little effort.

Some comments:

  • For both systems, it was necessary to manually install root certificates (instructions)
  • I’ve observed the “Missing XSRF Token” bug with both systems (link)
  • I haven’t checked yet if the restore bug is present on the DS218+, but can report back on this.

DS418play (DSM 6.2.1-23824 update 2) … Installed mono (4.6.2-0096 ) and Duplicati ( and Duplicati won’t run. Tried to launch using package icon and all I get is “connection to the server is lost”.


Hi @Random, welcome to the forum!

Can you tell if the connection lost message coming from a Duplicati page or DSM one?

If the Duplicati server is starting then crashing there should be a lot file recoding the error, but in not sure where it would be located on you machine.

I’ve got a “baby” DiskStation - a DS115j - but it’s got 3TB of storage available (I just cleaned out the junk last night). I just lost of bunch of personal data to a drive with a corrupted filesystem, and despite knowing better, I didn’t have a backup system in place. I’m running Manjaro (Arch) LInux, and I’m a developer. Thankfully, I regularly push my code to GitHub, so I can get that stuff back. What’s gone is all my pictures, music, settings, etc. Argh.

It’s really surprising to me that Synology doesn’t have a backup “backend” program that supports Linux. I’m going to keep reading the site (and studying this thread more carefully), but I hope there’s something better than having to manually schedule rsync or rdiff runs myself.

Has anyone tried putting a Linux backup server instance inside a Docker container on a NAS? That thought came to mind, but I’m not a Docker guy, so I’d have some learning to do.

When I’m in Package Manager I see Duplicati… it’s button says “Run” or “Uninstall”. I select run, and after a few seconds the button shows “run” again, instead of stop.

When I use the Duplicati icon (on the installed package dropdown (from DSM in browser tab), a Duplicati window appears with the “connection to the server is lost” message and then a countdown to the next connection attempt is displayed. I doubt there ever was a connection since the Run button is always present in Package Center.

UPDATE: After rebooting the NAS, I can now start Duplicati. Initially there was a popup that said Missing XSRF token, but that is now gone. So… off to experiment…

A post was split to a new topic: Restore bug on Synology if path has spaces