How to ignore duplicate file error (when deleting a version)

How do I tell Duplicati to ignore duplicates in the destination file list?

I’m trying to delete a backup version #, but it never gets that far because of duplicates reported, and I can’t resume backups without deleting the offending version (count mismatch error, which has been discussed in detail in other posts).

I have two Google drive accounts, both active. However, trying to send Duplicati backups to the second account using the “Google Drive” configuration option only sends to the first Google Drive, or can’t find the path on the second Drive (depending on configuration).

So… I tried defining the second Google Drive destination as a “local folder”, giving the local folder name(s) that the Google Drive app (on MacOS 11) creates. However, the Google Drive interface seems to return duplicate filenames when only one file actually exists. This is a Google Drive (not Duplicati) bug that I’ve seen when downloading directly from the Google Drive, which I’ve reported to Google, but no fix yet.

I tried a few options that looked promising (“disable filelist consistency checks”, “no backend verification”) without success.

Duplicati -, MacOS 11.6.7, latest Google Drive for Mac, Macbook Pro (mid-2014)

Duplicates were created by Google Drive app. I got a solution in another post to ask Google to give Duplicati access to my entire drive, not just the files created by my current userid. This worked around the problem, so I could go back to using the Duplicati GDrive interface directly. Thanks… Steve

1 Like