How to get Debian Duplicati Tray Icon?

Hello! Just got Duplicati and I am super happy with how simple this was to start using. The ONLY issue I am having is that I don’t see a tray icon and don’t see how to get it to work. I am following the guide on the website and don’t see instructions for Linux. Any help would be much appreciated but I am very new to duplicati and linux so please bear with me. Thanks!

Welcome to the forum @walrusbarretterura

Instructions are kind of scattered, and I guess Windows got Configuring the Duplicati Tray Icon in Windows but Linux didn’t get specifics. The general plan is similar though. Here are some other places that describe.

The TrayIcon package
Installing Duplicati on Linux (Ubuntu / LinuxLite)

Note that on Linux, you get to Duplicati.GUI.TrayIcon.exe through the /usr/bin/duplicati script. I’m not certain how to launch at login, which is actually the usual Windows way, where a service is hard to setup whereas on Linux the service is the default and the TrayIcon (which includes the server, unless told not to) is harder.

While learning Linux, I suppose you could search for recommended ways to start things at a user login.
I know one answer for Windows, which I think has the same design style that things that start at startup generally don’t get to put things on the user desktop the way things that start as the user are able to do.

To sample a user-started TrayIcon, try typing duplicati --no-hosted-server into a terminal window.
If that can’t find your systemctl service, then maybe add the --hosturl. If that then works, then search for what user-friendly facilities your particular Linux distro has to start programs at login. If all else fails, you should have some low-level means from the configuration files for whatever your shell is (maybe bash).

What Linux distribution and version are you using? And what window manager (Gnome, KDE, etc)? Some handle tray icons, some do not.

Debian 10. Gnome, I believe.

Let’s try to find out for sure. Does it look like this?

Yes! That’s it. That’s what I have.

Ok! Let me spin up a test machine so I can come up with some clear instructions for you.

Can you confirm how you are launching the Duplicati service? Did you enable the systemd service? To confirm, type this and let me know what it says:

$ systemctl status duplicati

Wow! Thanks so much for helping with this. I appreciate it. When I type in what you said I get:

duplicati.service - Duplicati web-server
Loaded: loaded (/etc/systemd/system/duplicati.service; enabled; vendor preset
Active: active (running)

Ok great, that confirms you enabled the systemd service which is what I suspected from some above messages. Will get back to you on the tray icon thing after I do more testing.

After a bit of testing, I’m thinking Gnome may not support support custom tray icons. Personally I use Linux Mint on one of my machines and I know the tray icon does work - but Mint doesn’t use Gnome.

Hey! I know this can make it so tray icons are enabled:

Cool find! I tried this but couldn’t get it to work. Were you able to?

Well, what I can get to work is when I enable that (and logout and back in) I get (apparently previously suppressed) system tray icons but not one for Duplicati.

Hmm, I couldn’t get it to work at all. Followed instructions, logged out/back in, but I saw no additional tray icons.

Oh well! I appreciate all the help. Just seems like there’s not a way to get a tray icon for Duplicati on Debian.

Is below still happening? You could work on that. There are suggestions on the Internet.
The exact tools and packages vary, but I’d guess Ubuntu methods will also fit Debian…

I don’t mean any disrespect but I’ve looked and can’t find a solution. The combo of also being new to Linux just ends up frustrating me, which is why I came to the official forums to see if there was a one stop solution.

Also, I thought this was supposed to make backups in the background without any user interaction once set up? I have it set to start when I login to my computer, but when I click the Duplicati program and it loads the localhost in my browser, it says the last back up was last Thursday when I manually did it…

EDIT: OK, I think there is an issue here. When I click the Duplicati program from my program list, it launches to localhost 8300. When I manually navigate to localhost 8200, none of my backups or settings are there.

EDIT2: Unfortunately when I try to set up a backup on localhost8200 it doesn’t let me select a source, there’s a blank list.