How to exclude sub folders on Windows

Can someone for the love of god, please help me exclude a simple sub folder on windows. Nothing more, nothing fancy, I just want a simple sub folder excluded from the backup.


– Sub Folder
– Test Exclude ← This is a sub folder
– – Noo ← This is also a sub folder, within “Test Exclude”
– – – Junk Files ← Files that I want excluded.

I want to exclude the “Noo” folder, but after 3 hours of futzing with it, with I don’t know how many repeated attempts to exclude. Test files that I add to my test directory ALWAYS appear in my backups.

I’ve tried the following:
Test Exclude is a sub folder
NOO is a sub folder within Test Exclude.

I do not want to exclude “Test Exclude” but only the contents within “Noo”

“\Test Exclude\NOO”
-"\Test Exclude\NOO"
-"\Test Exclude\NOO"
“/Test Exclude/NOO/”
-"/Test Exclude/NOO/"
"/Test Exclude/NOO/"

Among numerous other combinations and nothing ever seems to work. I cannot for the life of me figure out the proper syntax to exclude a single simple folder.

I’ve checked via “Edit as text” vs “Edit as list”, sometimes when I enter things as text, the filter type changes to “Exclude folder with similar name” or “Exclude expression” and again, I don’t know why this keeps changing.

Can someone please just drop me a sample or something to explain how to exclude a subfolder on windows?

Can you tell us what version of Duplicati you are using? Reason I ask is that some older betas had a bug in the Edit as List GUI exclusion screen.

I appreciate you getting back to me, but I think I realized my issue here, which was only after extensive trial and error.

It seems, to exclude the folder in question, my path also needed to include the root parent folder that was being excluded.

Instead of:

-*\Test Exclude\NOO

I needed:

-*\Root\Test Exclude\NOO

And despite spaces, this seems to work just fine without quotes.

Glad you figured it out. Normally you can easily exclude a folder by just unchecking it in the directory tree… The appropriate exclusion filter will be added for you in the lower section.

What’s missing from all the attempts is the trailing backslash that says it’s a folder exclude:


Folder names always end with a slash / on Linux or Mac and a backslash \ on Windows.

If you uncheck the folder in the directory tree, or use the “Exclude folder” choice, you get one.
What’s not well-documented is exactly what the tries-to-help filter builder actually produces…
Sample test results:

Deselecting C:\tmp\Test Exclude\Noo built filter
Exclude folder C:\tmp\Test Exclude\Noo
Edit as text
-C:\tmp\Test Exclude\Noo\
and backup respected that

Add filter Exclude folder C:\tmp\Test Exclude\Noo
Edit as text
*C:\tmp\Test Exclude\Noo*\
and backup excluded not only Noo but Noon (wrong)

You can test filters from a Command Prompt with The TEST-FILTERS command, however quoting is potentially needed to say where the breaks are (or aren’t). GUI Commandline won’t need quoting help.