High CPU ussage because --webservice-sslcertificatefile

I’m new to duplicati and i have it installed in my headless UBUNTU server 18.04 machine.

I’m trying to set duplicaty to use https instead of the default http interface.

According to my research, i just need to create an SSL certificate in PKCS#12 format for duplicati to use and and indicate the location of such certificate in the file /etc/default/duplicati by adding the option --webservice-sslcertificatefile

The last sentence of that file in my system reads as follows:

# Additional options that are passed to the Daemon.
DAEMON_OPTS= "--webservice-interface=any --webservice-port=8200 --portable-mode --webservice-sslcertificatefile=/var/servercertificate/Cerberus.p12"

As expected, with these settings Duplicati successfully uses https and my ssl certificate.

However, after i did this, the fans on my server just went wild. I checked the running services with the “top” command and noticed that mono-seg had a cpu usage between 50-100% in one of the cores.

So, i went back and deleted the --webservice-sslcertificatefile. All of the sudden everything went back to normal but i lost the encrypted connection via https that I was pursuing.

I honestly don’t know if this is a bug or if this is supposed to work this way.

I also noticed that everyone using --webservice-sslcertificatefile was also using --server-mode instead of the default --portable-mode option. I don’t have a clue of the difference between these two options or if using --server-mode would solve the high cpu ussage.

Has anybody experienced the described behavior? Or am I the only one?

It seems that this is not a very common problem and that my case is an isolated one.

I will keep investigating and report back if i ever find the answer to this but, I will focus my efforts on how my hardware interfaces with mono since nobody has commented on the software aspect of this.