Help with backing up to S3 target


#1

Con la version 1.3.4, puedo conectar perfectamente al mi servidor compatible S3, pero con la version 2.0.2.1, no consigo establecer la conexion.
Pueden ayudarme?
Muchas gracias

With version 1.3.4, I can connect perfectly to my S3 compatible server, but with version 2.0.2.1, I can not establish the connection.
Can you help me?
Thank you very much


#2

What S3 compatible server, what OS are you running on?


#3

ES de la empresa Arsys. NO se que sistema operativo usaran. Pero con la version 1.3.4 funciona muy bien

ES from the company Arsys. I do not know what operating system they will use. But with version 1.3.4 it works very well


#4

You note that it is failing to back up, so I assume you have it installed currently.
I’m glad to try to help, but I need more precise information to do so.

Questions:

  1. What operating system is duplicati installed on?
  2. What errors are you getting?
  3. Could you enable logging and set it to profile mode, and post logs here?
  4. You note Arsys EC. Do you mean Arsys ECS? Have you checked with them to see if they support the full slate of S3 APIs and options?

Regarding item #4, I’ve found that the S3-compatible backup target I use, Minio, is mostly S3 compatible. More than most of the others I’ve seen, but it still has a few items to note.

As I noted, I’m glad to try to help, but you’ll need to provide more information than what you have provided.

–Dave


#5

Lo tengo instalado en Windows 10 pro 1703. El error lo tengo al configurar la copia, cuando pulso en probar conexión. No conecta con el servidor.
Muchas gracias

I have it installed on Windows 10 pro 1703. I have the error when configuring the copy, when I click on test connection. It does not connect to the server.
Thank you very much


#6

Could you enable logging and set it to full profile level, and post those logs.

Please try to answer all the questions asked. This is a volunteer board, and I only have limited time to assist. The more information you can provide, the better I can help.
I do not have access Arsys ECS to reproduce, or time to do so.

Have you contacted their tech support?
If so, ask if they wrote their own code, or if they are using someone elses, that may help us diagnose.


#7

Primero. muchas gracias por tu tiempo.
Segundo. he tratado de contactar con soporte, pero ha sido imposible.
Tercero. Si funciona perfectamente la version de duplicati 1.3.4, y tambien funcionan perfertamente otros programas como Dragondisk, Iperius Backup, S3Browser, creo que si no funciona la version 2.0.0 de duplicati, seguramente sera por que hago algo mal a la hora de crear la tarea ya que mi servidor no ha cambiado nada.
Cuarto. Te digo como configuro la tarea y me dices si estoy haciendo algo mal.

Tipo de almacenamiento = S3 compatible
Servidor - Usar Url Personalizada = api.cloudstorage.es
Nombre deposito = xxxxx-1-prueba
Crear region en deposito = Default
Categoria de almacenamiento - personalizada = xxxxx-1
Ruta de la carpeta = xxxxx-1/Prueba
AWS Acceso ID =  xxxxx_1
AWS Clave de acceso = yyyyyyyyy
Le doy a probar conexion y da el siguiente error:
Failed to connect

First. thanks for your time.
Second. I have tried to contact support, but it has been impossible.
Third. If the version of duplicati 1.3.4 works perfectly, and also work perfectly other programs like Dragondisk, Iperius Backup, S3Browser, I think that if version 2.0.0 of duplicati does not work, it will surely be because I do something wrong when creating the task since my server has not changed anything.
Fourth. I tell you how to set the task and tell me if I’m doing something wrong.

Storage type = S3 compatible
Server - Use Custom Url = api.cloudstorage.es
Deposit name = xxxxx-1-test
Create region on deposit = Default
Storage category - custom = xxxxx-1
Folder path = xxxxx-1 / Test
AWS Access ID = xxxxx_1
AWS Password = yyyyyyyyy
I give you to try connection and gives the following error:
Failed to connect

#8

Hi,

You have some valid points. I’m certain we can get this working.
I’m sorry to hear that support is useless. If they have a support page you can access defining what parameters they accept, please paste that here.

A few thoughts/ideas::

  1. Go through and save the backup job, then go back and re-test. I’ve found that testing before saving the job always ends in failure.
  2. Try enabling option “s3-ext-forcepathstyle”
  3. Why are you using a custom Storage Category? (“Storage Class” in my english translation version).

–Dave


#9

Hola Dave.
He marcado la opcion “s3-ext-forcepathstyle” y he dejado la categoria de almacenamiento en “default”, pero sigue dando “Failed to connect” al pulsar el boton de conexion de prueba.
Ya me comentas si tienes alguna idea más.
Muchas gracias

Hi Dave.
I have marked the option “s3-ext-forcepathstyle” and I have left the storage category “default”, but it still gives “Failed to connect” when I press the test connection button.
You already tell me if you have any more ideas.
Thank you very much


#10

Buenas boches Dave.
He creado un nuevo espacio y te paso los datos para ver si tu puedes hacerlo funcionar.
Estos son los datos que pongo en Duplicati 1.3.4

S3 Server name: api.cloudstorage.es
ID acceso a AWS: cdc05665_4
Secret Key de AWS: NsfsPY9X
Bucket S3: cdc05665-4

Muchas gracias y un saludo.

Antonio

Good boos Dave.
I created a new space and I pass the data to see if you can make it work.
These are the data that i put in Duplicati 1.3.4

S3 Servername:     api.cloudstorage.es
AWS access ID:      cdc05665_4
AWS Secret Key:    NsfsPY9X
Bucket S3:              cdc05665-4

Thank you very much and greetings.

Antonio


#11

Hi,

Issue is that your S3 cloud provider only supports signature version 2. Solution is to add s3-ext-signatureversion advanced option and set it to 2.
Note that Amazon started only supporting signature version 4 for regions created after January 30, 2014, with regions older than that supporting signature versions 2 and 4. I would question why your S3 vendor is complaint with 3.5 year old standards.
http://docs.aws.amazon.com/AmazonS3/latest/API/sig-v4-authenticating-requests.html

BTW, I solved this by installing an S3 client and testing that way. My client was minio client, see Minio

Please test and verify, and let me know.

Dave


#12

Buenos dias Dave.
He probado, con duplicati, poniendo la opcion de “s3-ext-signatureversion a 2”, pero tampoco me conecta.
He mirado el cliente minio, pero necesito un programa de facil manejo, como duplicati.
Muchas gracias por tu interés

Good morning, Dave.
I have tried, with duplicati, putting the option of “s3-ext-signatureversion to 2”, but it does not connect me either.
I have looked at the client, but I need an easy-to-use program, such as duplicati.
Thank you very much for your interest


#13

I’m sorry, I didn’t explain. You simply need to set the Duplicati2 variable “s3-ext-signatureversion” to 2, and it’ll work for you.

I was attempting to explain how I troubleshot the issue, not suggest an alternative to Duplicati.

Try the variable/setting, and let me know when you get it to work.

Dave


#14

Just to clarify, this is the step 2 (Destination) setting you’re talking about, right?


#15

@hardsoft I believe that the above should resolve your issue.

I’m going to close this thread as resolved.


#16