Headless Linux - can't get remote access

Another Crashpan refugee here. Have been trying to set up Duplicati going to B2 storage from my headless Linux Server (Ubuntu 16.04) - following the instructions here: Headless installation on Debian or Ubuntu · duplicati/duplicati Wiki · GitHub

It seems to go OK - in that I get all the relevant authentication requests when I run systemctl enable at the end - except I cannot seem to get remote access. systemctl shows the following:

aidan@servr:/usr/lib$ systemctl status duplicati
● duplicati.service - Duplicati web-server
   Loaded: loaded (/etc/systemd/system/duplicati.service; enabled; vendor preset
   Active: active (running) since Wed 2017-11-15 14:14:34 AEDT; 21min ago
 Main PID: 2573 (mono)
   CGroup: /system.slice/duplicati.service
           └─2573 DuplicatiServer /usr/lib/duplicati/Duplicati.Server.exe

Nov 15 14:14:34 servr systemd[1]: Stopped Duplicati web-server.
Nov 15 14:14:34 servr systemd[1]: Started Duplicati web-server.
Nov 15 14:14:37 servr duplicati-server[2573]: Server has started and is listenin
Nov 15 14:35:46 servr systemd[1]: Started Duplicati web-server.

So it appears to be running at least, yet stubbornly refuses to connect from my PC on the same network…

Thoughts?

Your systemctl output seems to have been chopped off a bit - can you tell what’s showing after the “Server has started and is listening…” text?

I want to confirm that the --webservice-port–webservice-interface` parameters mentioned in your linked instructions (and here) are being used as expected:

By default Duplicati only listens on the loopback address (for security reasons) - since you’re looking to open it up to the network, do you think you’ll need the --webservice-password parameter as well?

Apologies, missed that truncation!

aidan@servr:/usr/lib$ systemctl status duplicati
● duplicati.service - Duplicati web-server
   Loaded: loaded (/etc/systemd/system/duplicati.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2017-11-15 14:14:34 AEDT; 44min ago
 Main PID: 2573 (mono)
   CGroup: /system.slice/duplicati.service
           └─2573 DuplicatiServer /usr/lib/duplicati/Duplicati.Server.exe

Nov 15 14:14:34 servr systemd[1]: Stopped Duplicati web-server.
Nov 15 14:14:34 servr systemd[1]: Started Duplicati web-server.
Nov 15 14:14:37 servr duplicati-server[2573]: Server has started and is listening on 127.0.0.1, port 8200
Nov 15 14:35:46 servr systemd[1]: Started Duplicati web-server.

Looks to me like it’s only listening on localhost?

…And yes, sure enough, I’d messed up the config file telling it to enable the webinterface.

Let’s see if it survives a reboot…

Thanks @JonMikelV for pointing me in the right direction :slight_smile:

Righto, seems to be working nicely now! Can see files turning up in my B2 storage :slight_smile:

Thanks again for the swift assisance!

Glad it’s working for you!