Headless installation won't start

Hi guys,

Duplicati runs fine out-of-the-box on my laptop, so I thought let’s try this on my (headless)Linux server.
I followed the instructions on GitHub - except that I used the duplicati_2.0.2.1-1_all.deb file as basis.

The Server runs Ubuntu 16.04.3LTS, Duplicati (and an Owncloud) runs in an lxc container.

And, sure enough, the installations completes successfully, all dependecies are resolved.
All files are complete, I only have to add the “DAEMON_OPTS=”–webservice-port=8200 --webservice-interface=any"" Option

When I try to start the service, however, all I get is this:

ubuntu@encrypted-system:/etc/default$ sudo systemctl status duplicati
duplicati.service - Duplicati web-server
Loaded: loaded (/lib/systemd/system/duplicati.service; enabled; vendor preset: enabled)
Active: inactive (dead) since So 2018-01-21 16:45:52 UTC; 1s ago
Process: 1123 ExecStart=/usr/bin/duplicati-server $DAEMON_OPTS (code=exited, status=0/SUCCESS)
Main PID: 1123 (code=exited, status=0/SUCCESS)

Jan 21 16:45:50 encrypted-system systemd[1]: Started Duplicati web-server.
Jan 21 16:45:51 encrypted-system duplicati-server[1123]: Ein schwerwiegender Fehler trat in Duplicati auf: System.Exception: Öffnen von Socket nicht möglich, versuchte Ports: 8200
Jan 21 16:45:51 encrypted-system duplicati-server[1123]:   at Duplicati.Server.WebServer.Server..ctor (IDictionary`2 options) <0x415c44c0 + 0x00be3> in <filename unknown>:0
Jan 21 16:45:51 encrypted-system duplicati-server[1123]:   at Duplicati.Server.Program.RealMain (System.String[] args) <0x4156e790 + 0x018d7> in <filename unknown>:100:

In a nutshell: It can’t open port 8200.

When I enter “duplicati” at the prompt, I get this:

sudo duplicati
Server gestartet und hört auf, Port 8300
[Server started and listening on, Port 8300]

I am a bit confused where Port 8300 comes from and why Port 8200 can’t be opened.

What am I missing here?


Are you using 8200 for sth else? Or is already locked by another instance? I believe 8300 will be tried if 8200 is not available but don’t know the details.

@Wim_Jansen is correct. Duplicati will first try the specified port (defaults to 8200) and if that port is not available will try additional ports in increments of 100 until one is available.

So in your case 8200 is unavailable for some reason so Duplicati tries 8300. If that weren’t available it would move on to 8400, then 8500, etc.

Usually the reason for 8200 not being available is because another instance of Duplicati is already running, as @Wim_Jansen said. Is it possible you had manually started the tray icon (which took port 8200) then while still logged in tried to start the service / daemon (which would get “bumped” to 8300)?

Thanks Wim & Jon,

you are right!
The server process indeed takes port 8200 and when I start Duplicati manually from the command line, it creates a second process that gets bumped to 8300.
I was able to repeat this on my laptop (where Duplicati runs already).

So this is not the cause for the server process failing to start.

My suspicion is that the lxc container Duplicati runs in has something to do with the socket issue reported when the process starts.
Ideas are welcome on this one :wink: