HDD-access speed during backup


#1

Hi together,

it si possible to control hard drive access speed during backup?
(I want limit it to 25-30MB/s)

regards,
ron


Duplicati slowing down my pc
#2

You can use the use-background-io-priority command to lower the priority of Duplicati’s IO accesses. This will limit Duplicati from hogging the disk during backups so that it will not interfere as much with other computer processes.


#3

GOT IT THANKS!

Hi BobW,

thank for your quick answer.

Did you know the value and where to set it correctly?
I run duplicati as a windows-service.

regards,
ron


#5

PS: Did you know if i set this value, it will work effective on a active backup/process?

regard,
ron


#6

No, settings are passed into a process at the start only. So you can make changes to a backup job while it’s running, but the changes won’t kick in until the NEXT run.

Image how ugly it could get if an actively running backup suddenly had a change in source folder, filte rules, or even destination! :crazy_face:


#8

Hi JonMikelV,

thx for this answer. I think you’re have some knowledge about the program…

I am a little bit confused about the filters with regex problems and the performance.

I turn on two filters:
-{OperatingSystem}
-{TemporaryFiles}

and two option:

–use-background-io-priority=true
–disable-file-scanner=true

Is it correct that the speed form access the hdd goes down to 1-2 MB/s?
Without filters and/or otions 70-105 MB/s.

I there an option or setting to find a “middle (gold) way”?

best regards,
ron


#9

Not really - most users seem to either want their backups to run as fast as possible using all available resources OR run as slow as necessary so as NOT to use all available resources.

Personally, I don’t care how long the backups take so I use --use-background-io-priority=true and --thread-priority=idle.

You may find that adjusting --throttle-upload and some of the concurrency settings (such as --concurrency-max-threads) might give you the speed / performance balance you seem to be looking for.


#11

Hi,

i try now:
–concurrency-max-threads=1

Maybe it help. IO is now ca. 12 BM/s on disc.

Thank you for this advice.


#12

Hi JonMikelV,

did you know how i exclude the:
C:\Users\XXXXXX\AppData\Local\Google…

or the complete “AppData” without the actually problematic “regex” default filters…

Many thanks in advance for yours help,
Ron