GUI not accessible - errors in log?

Hi there!

I’m using Duplicati for several years now, and I absolutely love it. It helped me out a few times where I was able to restore some critical data. It’s a life saver!

For the first time I’m experiencing a weird issue. I run duplicati in a docker container and now out of nowhere I’m unable to access the GUI.
When I start the docker I’m presented with the login screen (default IP:8200). So far no errors or messages in the docker log.

But when I type in my password in the web GUI and press enter, the page just keeps loading. Just ‘waiting for …’ in my browser.

Welcome to the forum @stijnos1991

Web GUI sometimes fails on Firefox gave some troubleshooting steps you might try.
If it’s Docker-specific then someone else will probably need to work on figuring it out.

I did some more debugging and the problem is getting stranger.
I have a site2site VPN via Wireguard. The duplicati host is on the ‘other’ site of this tunnel. This remote subnet is available on my home network. That means I can directly SSH into this Duplicati host, view web pages from other services (there are other services with web GUI’s on that host that work perfectly fine) from my home LAN. This all works, e.g. the tunnel is working fine and I never experience(d) any problems since a few weeks, where ONLY the Duplicati GUI is not accessible from my home LAN.

The strange thing is, when I connect a phone to this Wireguard VPN the Duplicati GUI is accessible! Same VPN. I tried multiple browsers and that doesn’t make a difference. Devices behind the site2site VPN cannot reach the web page on port 8200 anymore, whereas devices ‘directly’ connected to this same VPN connection are able to reach it. With the weird thing being that devices behind the site2site VPN can reach any other service and web page on the Duplicati host, except the Duplicati GUI. I just don’t understand how this is possible. For now problem sorta solved, I can reach the backup server again, but it remains a mistery.

Duplicati has a bit of a programming issue as far as showing the GUI. At least for me it times out the first time then the second time after waiting for the process to exit from the first, the GUI will be shown.

Haven’t looked into it much further than that but I think its already around on the forum or github.

The biggest thing is as long as its still making backups then its not a huge deal. If backups weren’t running because of it then that’s a huge deal.

Can something simple like telnet <IP> 8200 connect?

Do you access Duplicati using IP address or host name? There is a host name check.


I’m not sure if DNS issues can cause issues, but I guess you could dig -x some IPs.

Is there a web browser there that you can start and display to an X server at your end?
You can then try accessing Duplicati over localhost and other interfaces to test results.