GUI crashes quickly after launch, HTTP 500 error

I have (had) an issue while loading the GUI on my Windows PC. It would sit for about 30 seconds while it threw this error continuously until it crashed:

Feb 7, 2018 1:03 AM: UsageReporter failed
{"ClassName":"System.Net.WebException","Message":"The remote server returned an
error: (500) Internal Server Error.","Data":null,"InnerException":null,"HelpURL":null,"StackTraceString":"
at Duplicati.Library.Utility.AsyncHttpRequest.AsyncWrapper.GetResponseOrStream()\r\n   at 
Duplicati.Library.Utility.AsyncHttpRequest.GetResponse()\r\n   at 
"RemoteStackIndex":0,"ExceptionMethod":"8\nGetResponseOrStream\nDuplicati.Library.Utility, Version=, Culture=neutral, 
PublicKeyToken=8bfe994a39631a7b\nDuplicati.Library.Utility.AsyncHttpRequest+AsyncWrapper\nSystem.Object GetResponseOrStream()",

The issue is very similar to this post, and I fixed it the same way (disabling error reporting.) I am almost 100% certain this is caused by a new addition to my home network: an Unbound-based DNS server with an extensive blacklist, and the domain used for reporting might have made the list accidentally. I believe it is the only real change to my setup that could cause this error. Is there a particular domain that Duplicati uses for reporting? If so, I can remove it from under the shadow of my shiny new banhammer and let it run as normal.

To me it looks like the only usage logging domain the code is

However, I’ve tried simulating this problem by routing that domain to and I’m not finding any of those errors in my logs. For now assume I’m either misunderstanding the issue or the issue isn’t connectivity so much as an actual error with the usage-reporter server (perhaps it’s overloaded).

If you have the time, when this happens again can you try pinging to see if you can reach the host?

When I visit that link, it works just fine (in my browser.) Thank you for ruling out an error on my part. I should mention that since I posted, I got frustrated with the system I put together and switched to the pi-hole ad blocker project. I can reach the reporter url using either system.

So what could I do to assist in troubleshooting? I don’t see any other errors in the log files, just the one in the OP repeated a couple dozen times before the program crashes. Regardless, is there anything I can provide to help?

This seems to be a known issue: