GUI and command line disagree on number of versions and size on Linux (Fedora 34)

I just went through a process of using the command line to purge unneeded files from some backups, as well as deleting some backup versions. Using “list” from the command line shows that there are 8 filesets, each using 4-5GB. But the GUI shows 21 versions using 144GB.

I have tried a few things to get the GUI to show the current number of filesets/versions:

  • restart duplicati.service
  • vacuum
  • delete/recreate database (after saving a backup copy, JIC)
  • restore a file

The one thing I specifically have not tried is to run a new backup, because this is an older, obsolete backup config that has been replaced.

Is there a way to get the GUI to acknowledge the changes?

The stats shown in the web UI will be updated after the next backup operation.

Are you saying that since there will never be a new backup (using this configuration), the stats won’t ever get updated? [There is a 2nd backup that has run and it had no effect on the stats for the backup in question.]

Correct. I’m not aware of any other way to refresh the stats.

Yes, that’s correct. After a backup job runs only the stats for that job will be updated.

Thank you! It is a minor annoyance I can live with. I suppose I could always de-select everything except a single small file and run an additional backup if it annoys me too much…

I don’t understand why you’d need to deselect anything. If you run another backup and nothing has changed, it should finish very quickly and update the stats.