Google One / Google Drive > Error 403 when scheduled but ok when run manually?

I set up a Backupjob to Google One which is running 16:00. When it starts an Error 403 is generated. When clicking on “Details” I don’t see an entry for the try.

When I start the job manually it’s running as expected.

Any idea what’s causing this?

Win10.1903 (18362.462)

Is this all through the Web UI? If so, I don’t know why it would be different depending on start method. Getting a better view of things e.g. on the About --> Show log --> Retry screen might reveal more info, such as what operation (e.g. directory listing, upload, download, etc.) got the error, and if any worked.
Sometimes clicking on <job> --> Show log --> Remote entries that errored will expand into details too.

Yep, that’s also what makes me wonder, 'cause I don’t see the difference either

As for the log from About > Show Log > Saved see here:

System.Net.WebException: Der Remoteserver hat einen Fehler zurückgegeben: (403) Unzulässig.

   bei Duplicati.Library.Main.BackendManager.List()

   bei Duplicati.Library.Main.Operation.FilelistProcessor.RemoteListAnalysis(BackendManager backend, Options options, LocalDatabase database, IBackendWriter log, String protectedfile)

   bei Duplicati.Library.Main.Operation.FilelistProcessor.VerifyRemoteList(BackendManager backend, Options options, LocalDatabase database, IBackendWriter log, String protectedfile)

   bei Duplicati.Library.Main.Operation.BackupHandler.PreBackupVerify(BackendManager backend, String protectedfile)

   bei Duplicati.Library.Main.Operation.BackupHandler.<RunAsync>d__20.MoveNext()

--- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---

   bei System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()

   bei CoCoL.ChannelExtensions.WaitForTaskOrThrow(Task task)

   bei Duplicati.Library.Main.Controller.<>c__DisplayClass14_0.<Backup>b__0(BackupResults result)

   bei Duplicati.Library.Main.Controller.RunAction[T](T result, String[]& paths, IFilter& filter, Action`1 method)

   bei Duplicati.Library.Main.Controller.Backup(String[] inputsources, IFilter filter)

   bei Duplicati.Server.Runner.Run(IRunnerData data, Boolean fromQueue)

Remote Entries log doesn’t show any entry for the automatic start, only for the manual one.

Does the “Test connection” button work? Above live log failed in a directory listing, before backup itself. “Test connection” button gets a listing as a basic test, however I don’t think Duplicati can schedule that.

You could certainly run Duplicati.CommandLine.BackendTool.exe to see if its list at 4 P.M. can work. The Target URL that you provide it would probably be similar to what Export As Command-line shows.

You could also take that Export and run it at an actual command prompt, although don’t do it while the scheduled GUI version is running, because they’re independent so may trip over each other somehow.

Using the Command line tools from within the Graphical User Interface would be a third way to backup.

Making backup job unscheduled but running it manually exactly when PC clock hits 16:00 can be tried.

Are you doing any other activities to Google Drive at 4 P.M.? It has lots of rate limiting among its many 403s, which you can look at to see if any others make sense as the possible 403 that you’re getting in:

Yep. Test-Button works as intended.

I changed the execution time now to daily and the first job ran without error.

Will monitor this over the week and report.

You will have to log out of all logged in Google Accounts, then log back into just the 1 account you wish to use for the access.

Hm, interesting thought. But I’m not logged in at all.

And I thought the Google-Auth is done for the software not for the browser. If that’s correct why should it matter which account is logged in at the time of the backup?

Just for curiosities sake I logged in with one of my clients accounts and let the backup start on schedule. Ran without a hitch.

As it did already the whole week I must add. I’d assume it’s sth on Google side which had produced the error. I’ll close this thread now and will add when sth new shows up.