Google drive oauth token generation link returns 403

I have been encountering the following error every time I attempt to run a backup to google drive (which for months has worked fine):
Failed to connect: Failed to authorize using the OAuth service: Forbidden. If the problem persists, try generating a new authid token from:

However when I go to to generate an authid token, I receive the above pictured 403 error.

Would appreciate any advice on how to proceed.


Welcome to the forum @db0

Directly? It’s supposed to go to a screen like below. Or do you mean after you clicked it to continue?

What OS and browser is this? Is there any security, privacy, or network software possibly interfering?
Sometimes browsers have ways to open windows with plugins off. Or try a different one somewhere.

You can test a full Duplicati OAuth Handler at

In either case, browsers often have web developer tools (sometimes via F12) to show network action.
Something sent a request that Google didn’t like. Clicking to continue here takes me onto Google, e.g.: ... (etc.)
or ... (etc.)

If there are any web developers out there, please feel free to join in, if it gets into using developer tools.

Hey yeah I tried today without using Proton VPN and that seems to have solved it. Not sure why it was not working with protonvpn though :confused:

1 Like