Google Drive Authentication fails from within Docker container

I’m certain this is specific to my docker container. But I’m not sure how to figure out what I’m doing wrong.

If I use the “Test Connection” button on the “Destination” tab, it fails.

Failed to connect: Failed to authorize using the OAuth service: Error: TrustFailure (The authentication or decryption has failed.). If the problem persists, try generating a new authid token from: Duplicati OAuth Handler

I tried using the same Google account on another job via a Duplicati instance that isn’t running in Docker, and it worked perfectly. This was after I made sure both Duplicati instances were running

I tried getting a new OAuth token. That did not help.

I believe I have the networking configured correctly. I can ping from within the running container.

I also thought there might be missing ssl certs, so I made sure to install ca-certificates.

Is there a way to generate a more detailed error message?

Here is a gist of my code:

Figured it out. ca-certificates is not enough. I needed ca-certificates-mono as well.


Hello, I’m having the same problem, what exactly did you do to solve this problem?

Did you install this certificate package on the host?

My server is ArchLinux, I have no mono.

[tales@t4l35 Duplicati]$ sudo pacman -Ss ca-certificates
[sudo] password for tales: 
core/ca-certificates 20181109-4 [installed]
    Common CA certificates (default providers)
core/ca-certificates-mozilla 3.63-1 [installed: 3.62-1]
    Mozilla's set of trusted CA certificates
core/ca-certificates-utils 20181109-4 [installed]
    Common CA certificates (utilities)

Is this the same server as described below? If so, mono goes with Duplicati. It’s what runs the code.

Who provided the Duplicati Docker? I don’t use Docker, but generic mono TLS troubleshooting info is
Secure Socket Layer (SSL) / Transport Layer Security (TLS). Note mono has its own certificate store. Prebuilt images “should” take care of that. If you’re building your own, that’s something you must do…