GetRequestStream timed out during backup on Linux Mint 18.2


I have a dual boot computer, Windows 10 and Linux Mint 18.2. I’m using Windows 10 hardly, just for some specific tasks.
So, the Linux Mint 18.2 is my daily used boot partition.

To start with, the error message I get with Duplicati (see below) only appears using the Linux Mint 18.2 and NOT when using Windows 10.

I have installed Duplicati (latest at the moment) on a Linux Mint 18.2 system.

My storage device is in the cloud, using the Webdav from Duplicati.
The connection is setup and a backup starts but never finishes.
I get the following error message:
Failed to connect: GetRequestStream timed out

The size of the backup was about 900MB.
I tried to change the size of the volume files (default 50MB). Smaller and bigger. For smaller files, no change, same error message. For bigger files, there is a change. For a size of 400MB the backup successfully ends and continues with “Waiting for upload…”. And then after a while the same error message appers again.

So, I looked at the cloud storage throug a webinterface. I saw that just only three files arrived there. So there are files missing.

Any idea how to solve this? Why is it working on Windows 10 but not on Linux Mint 18.2?

This indicates that the error happens because the remote server does not respond to the request. Figuring out why is tricky, and it could be because the request is caught somewhere on the local machine.

For starters, do you have the latest Mono, installed from here:

1 Like

Installing the latest version of Mono solved the problem!
Thanks for pointing this out to me.

I didn’t realize Duplicati requires this latest version.

Thanks again.

1 Like

It does not “require” it, in that it runs on older versions too.
But there are many bugfixes between Mono 3.2 in Debian packages and the current 5.2.