FTP stopped working after update

I’ve been using Duplicati for years with no problems. After updating to I could no longer access my My Book Live nas. After the update I noticed the destination was changed to a local drive. All my other settings were unchanged. I changed the destination back to FTP along with server, path, id and pw (same as it’s always been for years) and it tells me Failed to connect: Unable to connect to the remote server. I tried turning of the windows defender firewall, but the problem remains the same. I’m using w11. I need help. Thanks.


between the 2 betas, TLS 1.3 support has been added. However it’s not really triggered for FTP before Win 11. There has been already one report of bad problems with this, so it could be that you need to change the advanced option ssl-allowed-version from System default to TLS 1.2.

I changed from default to TLS 1.2, but the issue remains the same. Thanks for the idea.

From what?

You looked at the job immediately after the Duplicati restart after update, with no other work on it?

The job definitions are in Duplicati-server.sqlite, but the last version upgrade to it was in 2018, and
therefore updating Duplicati (unless it’s super old) wouldn’t feel like it had to change the database. Changes would leave behind a backup copy which you can look for, but I doubt that DB upgraded.

Job databases (the ones with seemingly random names) update, but that’s not where settings live.


Are you sure it was on FTP before, not FTP (Alternative)? Which of those are you using currently?

I tested Duplicati beta from a Win11 VM to a proftpd server installed in a Ubuntu 20.04 container with success, so it should be possible to make work this setup. Proftpd needed the special option NoSessionReuseRequired though, probably to work around the TLS 1.3 ‘features’ of Windows 11.

Yes. I looked at the job immediately. It was ftp (not ftp alternate) for years. Immediately after update it was showing Local drive. I changed it back to ftp and entered in the other parameters on the page same as I was using and I also went on to check if any other settings were changed on the other pages. The other pages where not changed. I’m not sure, but I don’t remember ever having updating duplicati in the past. I did do a clean install of my w11 earlier this year and downloaded a current version of duplicati from their website at that time if that helps. All worked well and I was using ftp. I’ve always used ftp, never local drive or ftp (alternative). Seems to me, regardless of the history, ftp should just work if the parameters are correct.
I’m using:
SSL box unchecked (port left blank)
\bruce\duplicati backups
ID and PW entered correctly.

There are two backslashes in front of bruce. ie, \bruce\duplicati backups.

that’s not how a FTP path is entered, it’s a SMB path. How it worked at any time is just strange. But that may be why it was changed when upgrading. Are you sure that it worked with FTP ? Is FTP is enabled on your NAS, that is, on your Win11 computer if you enter ftp in a Terminal session does it connect ?
For the record, I unchecked SSL on my test setup and it worked immediately, there is no problem with FTP with current Duplicati.

Do you recall what was in the fields below that, such as


although I still find this perceived automatic change extremely strange. I can try setting it up
assuming we can settle the question of the odd (probably wrong) way of typing in FTP path.

Sometimes people get confused by multiple Duplicati. This is more likely for service installs.
If this is a simple ordinary user install, About → System info should show the following lines:

ServerVersion :
BaseVersionName : (likely)
StartedBy : Tray icon
UserName : <you>

Probably Beta, assuming it was a Beta (most people don’t go for the testing versions of Canary).

There are two versions of FTP specifically because not every FTP client can run with every FTP server.
FTP has been used for 52 years with many variations (and bugs). Look at this web page for some data:

FluentFTP. This provides Duplicati FTP (Alternative) – regular FTP is Microsoft, and it does what it does. When one doesn’t work, try the other, although I don’t see why regular FTP has just begun showing this. There have been no changes since June 12, 2021 change for many storage types that has seemed OK.

You can debug a connection problem well with Wireshark (which is harder) or netstat (which is easier).

netstat -an | findstr

You can run that line a few times during Test connection on Destination page, during a backup, etc.

EDIT: “Failed to connect” could probably refer to many places, but one at start will stop any FTP client.

Above quote has been fixed by putting path inside backticks (otherwise forum deletes a slash).
I tested this style to FileZilla Server which has a log, so is easier than watching with Wireshark.

(000005)6/10/2023 8:10:26 AM - duplicati (::1)> CWD //nas/test 1
(000005)6/10/2023 8:10:26 AM - duplicati (::1)> 550 CWD failed. "/nas/test 1": directory not found.
(000006)6/10/2023 8:10:31 AM - duplicati (::1)> MKD //nas/test 1
(000006)6/10/2023 8:10:31 AM - duplicati (::1)> 257 "/nas/test 1" created successfully

so something corrected the slash direction, didn’t correct double slash, but this server worked anyway.


OK I’ll ask the question despite previous replies indicating otherwise. Do you ever access NAS by SMB using the backslash syntax, and does the \\bruce syntax get you there? This depends on NAS’ name.

No. It did not connect.

PS C:\Users\bruce> ftp

ftp: connect :Connection refused

Storage type is correct
Folder path was as I remember looked simple such as c:\users\bruce\duplicati or c:\duplicati.
Username and pw were not populated.

Can you tell me how I should connect to my nas? Right now I have mapped my networkdrive to z: and I am using the Local Drive option to connect. Is there a more efficient way to connect? I thought ftp was the way, but it sounds like it’s not and some quirk in the previous version of duplicati was allowing me to do what I was doing.

This is what I got. Did it connect ok?

PS C:\Users\bruce> netstat -an | findstr
PS C:\Users\bruce>

No. I’ve never used SMB.

No. FTP would be port 21. 445 is SMB. It’s not too surprising it’s in use, as your Z: drive likely uses it.

You’re using it right below, although possibly you mean you’ve never used the double-backslash style:

Refusal is an active action, and probably pretty quick. It means the NAS is on, but its FTP server is not.
Alternatively there might be a firewall somewhere that does the refusal. Can any system FTP to server?
Does the NAS have a command line? If so maybe it has an FTP client, so try to FTP to NAS from NAS.

This is sounding increasingly bizarre. The chances of Duplicati just making up the path are very remote.
It was slightly bizarre when the claim was that Duplicati changed storage type all by itself. This is worse.


if NAS has command line, you could run netstat -an | grep 21 to see if FTP port 21 is LISTENING.
This would be especially suspect if FTP works from nowhere. Maybe you can restart NAS at some time.

I don’t know your hardware, from what I see on the Internet it has the possibility to manage an access through FTP, so you could connect to the Web user interface and verify that it’s enabled. If yes that’s a mystery why you can’t connect now. If not you probably never used FTP in the first place :slight_smile:

Guys. I figured it out from the things you all said. I tried using Local folder or drive and also `\networkdrive\bruce\duplicati backups\ and it worked! So simple. As you all can tell, I’m not so good with this networking stuff. Thanks for all your attention and help here.