Fix for Kaspersky Internet Security blocking Duplicati's Server

I’ve ran into the issue that the firewall of Kaspersky Internet Security blocked Duplicati’s server and therefore hindered Duplicati’s startup. Even though I could see Duplicati’s tray icon, after double-clicking it, the browser loaded the local address http://localhost:8200/ngax/index.html forever.


  1. Go to Kaspersky -> Setting -> Protection -> Firewall -> Configure application rules.
  2. Search for “Duplicati”
  3. Right-click Duplcati.GUI.TrayIcon, select Network rules -> allow.

This worked for me two days ago, however, strangely enough, I had to explicitly add an ‘Allow’ rule today for it to work again:

  1. Right-click Duplcati.GUI.TrayIcon, click “Details and rules.”
  2. In the tab “Network rules” click on “Add”.
  3. Fill in the data as shown in the second screenshot (or its ‘alt’ description) below.
    I only use Duplicati to backup data to my external hard drive. In case you use it to upload your backups to a NAS or online storage, you might want to set “Address” to “Any address”.

I hope this helps other users encountering the same issue. Maybe this should even be mentioned on the download page or recognized by Duplicati itself. A simple self-ping should do the trick, shouldn’t it?

1 Like

I want to keep the download page as clean as possible. Having workarounds for various products listed there will really muddy the page. I like it much better as a forum post, so others can likely find it when they encounter problems.

That depends on how it is done. The tray-icon is actually keeping a constant connection to the server, so it should notice the problem if it is done on a socket level. But perhaps the firewall is not blocking same-process communication?

Hello ComFreek and Kenkendk,
thanks for the fix, appearantly the same problem appears with Kaspresky free, except that you cant’t open the Firewall in Kaspersky free. Tried to allow port 8200 in the Network settings but this does’t help either. The Web-Frontend is only reachable if Kaspersky is deactivated temporarily. Is there another fix for this Problem?

Not that I am aware of. I think you should file a bug with Kaspersky, but my guess is that this is a limitation of the Kaspersky Free version.

I removed KAS =))) now i’m using only Windows Defender

I’m using KIS (Kaspersky Internet Security) with no problems. I have reinstalled Duplicati several times and didn’t have to do any additional configuration.