First Time User ... [Error] Element with Path Not Found On Host


I’m using a QNAP NAS TS-253Be QTS
Microsoft OneDrive For Business 5TB

I’ve followed some instructions from this website and QNAP’s Forum. As far as I can tell I’m doing everything that has been suggested. At (2) Destination the connection test returns the message “Connection Works!”.

This is how I’ve set up the destination:

Note:In “Path on Server” I’ve tried /personal/name_domain_com/Files/QNAP, /personal/name_domain_com/Files/QNAP/, and /personal/name_domain_com/Files/, and /personal/name_domain_com/ … none of them work.

This is what is returned after “Verifying Backend Data” is run (its the same for any path I try) …

Is this an issue others have run into?


using /personal/name_domain_com/Documents/ and not /personal/name_domain_com/Files worked … finally!! Its working :slight_smile:

Consider switching to the v2 backend. The one you are using is deprecated by Microsoft.

Firstly, thanks for the reply.

Also, as I’m only new to this, how would I go about doing that. Is there a post here you’re able to point me to?

Thanks again, appreciated.

Hello, again.

I’ve done as you suggested, however, it took 6 hours to upload 167kb … whereas the depreciated backend uploaded all the data.

Are you able to tell what troubleshooting steps I can take to get my data to upload using OneDrive v2?

What kind of data are you backing up? This looks like a giant (not really realistic) compression ratio to me. What kind of files do you see at onedrive?

Could you export the config to command line so we can have a look at your config.

Its just .pdf files (eBooks, receipts, offical documents, medical info, manuals, guides etc)

I deleted what was in OneDrive and started again. However, the upload rate is really slow.

Ok, newb question. How can I export the config to CL? I understand the basics of CL but I forget things easily. Still learning.

Thanks for your help, I really appreciate it.

Ok, that was easier than I thought. Here you go …

mono /share/CE_CACHEDEV1_DATA/.qpkg/Duplicati/Duplicati/Duplicati.CommandLine.exe backup "onedrivev2:///Duplicati/?authid=xxxxxxxxxxxxxxxxxxPRIVATExxxxxxxxxxxxxxxxxx/share/CE_CACHEDEV1_DATA/My Documents/" --tempdir=/share/CE_CACHEDEV1_DATA/backup_tmp/ --backup-name="My Documents Backup" --dbpath=/share/CE_CACHEDEV1_DATA/.qpkg/Duplicati/.config/Duplicati/67857667848472848982.sqlite --encryption-module=aes --compression-module=zip --dblock-size=5TB --passphrase=“xxxxxxxxxxxxPRIVATExxxxxxxxxxxxx” --disable-module=console-password-input

This wil try to put all files in one single file -(dblock) of 5TB. You should change dblock to eg the default 50MB or other.

ahh, right. I see now. I thought that I had to set it to the maximum storage space of my OneDrive account. Excellent, thank you.

Perfect, works without error now. I have a slow upload rate so I kept it at 50MB.


Nice to know that it worked. Could you please mark the post with the solution to the original problem as the solution?

Done, thank you. And thank you to @Wim_Jansen for solving everything, much appreciated. I hope someone finds this thread useful.

1 Like