First install, unable to connect


#1

I am exploring various backup solutions for some servers for the small company and running into an issue post installation with duplicati, it installs no errors and then thats it. Comes up with the icon in red with the X, then the URL. http://localhost:8200/index.html (in IE11) with a blank page.

Dev server that I use:
OS: Win Server 2008R2 SP1 x64
Plenty of RAM (32GB) and hard drive space (40G free OS drive + 8TB for storage (where the backups would go if I could ever get this working).
VC C++ Redist 2015, .NET 4.5.1
Windows Firewall is off (behind corporate firewall)
Duplicati version 2.0.3.4 x64 msi. I tried with beta 2.0.3.3 but that had same problem (removed and cleaned up before installing 2.0.3.4).
Tried from another PC to the IP http://10.0.0.80:8200/index.html (example IP) and comes back with “unable to connect”. Opening the file directly from C:\Program Files\Duplicati 2\webroot\index.html displays same blank page. Opening login.html does display a simple login but no idea what the default password should be since it never came up for the initial post-install setup.
Does this need the IIS or Apache to be installed and running? If so there was no mention of this in the prerequisites. Event viewer comes back with no errors. Based on what I am seeing from the desktop attempting to access it is equivalent of no Apache running.


#2

I was able to resolve this.
Server had SP1 installed, but it had not yet installed the Windows Updates for IE11 (and others), so it was still trying to access it via IE8. After I got that updated and rebooted the server I was able to get in.
After that I enabled remote access which now allows access from my desktop PC.
It does still shows the red icon with the X but I have not run the first backup yet, I have that scheduled for after hours today, and I will check the logs tomorrow morning.


#3

There used to be a bug where the red X would show in the tray icon until your first successful task (backup, file list, etc.) but I thought that had been fixed…

By default Duplicati doesn’t accept connections from other machines - only localhost (though you can add a parameter to the server to accept external connection requests).

To be honest, I don’t know that the GUI was ever tested as far back as IE8 so it’s possible something in the CSS or Angular is incompatible.

I do know some users have reported blank screens when JavaScript is disabled in the browser so an update has already been started to include a <noscript> tag so people will at least get SOMETHING showing in situations like that (and possibly yours).

Let us know how the backup works for you!