Find command lists all files in backup instead of specified file


I wanted to do some sanity checks on my backup using the command line GUI in the browser. Using the compare command works fine and shows the modified files.

When I use the find command for a specific file, e.g. “*outlook.pst”, all files in the backup get simply listed. I.e. I get a listing of all files, similar to “ls -r” in Unix. As this takes a long time I have to cancel this.

If I run find without specifying any file/pattern, I get the following output:

 No files matching, looking in all versions
 No files matched expression
 Return code: 0

According to the manual, “If no <filename> is specified, a list of all available backups is shown.” So this is also not the expected behavior.

Any ideas?
Thanks, Heinz

I’ve not been able to reproduce this.

When I supply *2.iso as argument to the find command for a backup that contains a bunch of .ISO files, I get a list of all files with .ISO extension, all file names ening with “2”.

Supplying * returns a list with all file names in the most recent backup.

No argument returns a list of all backup versions.
This is in accordance witrh the documentation.

What arguments did you exactly provide in the Commandline arguments section and what Advanced options are used?

When clicking on “commandline” in the GUI, I get a screen pre-populated with the arguments for the backup operation.

I changed the command to “find” and only the commandline arguments to the file I wanted to find. It seems that the exclude option prevented “find” from listing the proper information! So that seems to be the solution.

I left all other options unchanged, as some of them are apparently necessary, because when I deleted all, the command did not work.

BTW: the GUI always says “performing backup”, even if I run the “find” command.

Final question: is there an option to get the command exported to a .cmd file instead that the GUI executes it?

Thanks for the quick reply, Heinz

He @likesource, and welcome to the forum!

I’ve got a fair number of filters and haven’t run into that issue, but then,maybe it’s a specific type or string affecting yours.

For me, all I do is replaced the “Commandline arguments” with what I want to find and leave everything else alone.

Yes, depending on the Command some of them are still needed. For find the only one required is --dbpath.

Yeah, I’ve noticed that too. It’s probably a fairly easy thing to change, but I don’t know the UI side of things well enough to do it myself.

Unfortunately, currently that’s not available. Though it’s also something I’ve wanted for a while. It’s probably more detailed to put together than simply changing button text on the GUI but I expected it would be something similar to the “Export As Command-line” feature in the job menu.


I have had the same problem occur two days ago. The only difference between previous successful “find” operations and this one was, like yourself, some filters I had added to my backup. When I remove these filter statements from the “find” command, it works as advertised and expected. So, at least there is a workaround.

Regards … Noel

1 Like