Find and purge have different results

I have temporarily saved various large files in a directory that I would like to delete from the backup (several backup sets). As this was a while ago and I want to keep the other files in the backup sets, so ‘DELETE’ is not an option.

I can list the files without any problems:

"C:\Program Files\Duplicati 2\Duplicati.CommandLine.exe" find "file://\\my-nas\home\Duplicati-Backup/?auth-username=Jens&auth-password=secret" "c:\Users\Jens\Same Prefix *" --parameter-file=param.txt

If I now replace the command find with purge, nothing is found:

"C:\Program Files\Duplicati 2\Duplicati.CommandLine.exe" purge "file://\\my-nas\home\Duplicati-Backup/?auth-username=Jens&auth-password=secret" "c:\Users\Jens\Videos\Same Prefix *" --parameter-file=param.txt

The param.txt looks like this:

--backup-name="Backup PC"

I have also read here in the forum that the alternative is not to specify the file name/path as the 3rd parameter, but to use --include instead. However, this also leads to the same result: find lists the files searched for, purge does nothing.

Why do the filename/include parameters for find and purge work so differently and how do I have to modify the purge command so that it works as expected? (I’m using version

I think I have now solved the problem by myself. The purge command gave me no results when I first tested it with the --dry-run option. After adding --console-log-level=information, I can see what would happen.

This is confusing… I expect a critical command like PURGE is reporting the affected files without an explicit log-level.

Am I doing something wrong?

well, a long time contributor to this forum seems to think it is wrong too:

Note that this concerns purge-broken-file, but the post hints that there was a regression because of a logging change, so a general problem.

Thanks for the information and link. Then I’m not so wrong after all.
Is there a bug entry and the chance of a fix? I couldn’t find anything quickly on GitHub.

That’s because you were too fast. See set default log level to Dryrun if dryrun option is set by gpatel-fr · Pull Request #5059 · duplicati/duplicati · GitHub

Wow, you were fast and fixed it immediately. Great! I wish I were be a programmer too… Many, many thanks!