Filters: excluding Win office temp files


#1

Hi everyone,

first off, let me say that Duplicati works great and I am really glad for your work! There is one thing, though, that keeps annoying me and thatI just can’t seem to solve:

Whenever one opens a Microsoft Office file (e.g. Word), the program will create a temporary file with the following name: ~$[ACTUAL FILE NAME].[EXTENSION, E.G. DOCX]. Those temp files remain on the hard disk as long as the corresponding file is opened. Since I frequently leave a bunch of office documents opened for extended periods of time, Duplicati will always try to backup the automatically created temp files (which it can’t, since they are locked by the corresponding program) and produce an error message.

Could anyone help me out with a filter rule that will exclude suche files?

Thanks very much in advance for your help!

Cheers,
a happy Duplicati user


#2

Has really noone encountered this problem before? I tried some more filter settings but still get error messages of this kind:

Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: ~$file.xlsx

I only get this kind of warning for such temporary files. Additionally, I tried to specifically exclude this file (Filter: -~$file.xlsx) or to exclude all files of this type (Filter: -~*.xlsx). Neither of those fix the problem.

I am thankful for any suggestions.


#3

You can use Regex to exclude temporary Office files:

Or run Duplicati with administrative privileges and use option –snapshot-policy=required to create a snapshot before the backuperation is started.