Filter Problem with Duplicati on Windows 10


I backup my Windows 10 system to OneDrive Business and this is working fine except the filtering. I defined many filters and some working an some not. I have checked the RegExp (.NET Regex Tester - Regex Storm) and it seems OK.

I get always warnings like that:
[Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: C:\Users\MyName\AppData\Local\Vivaldi\User Data\Default\Sessions\Session_13255081618267523
2021-01-15 18:01:23 +01 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: C:\Users\MyName\AppData\Local\Vivaldi\User Data\Default\Sessions\Tabs_13255081618528704

So I created this RegExpr Filter without changing something:


Another warning is:

2021-01-15 18:00:57 +01 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: C:\ProgramData\Microsoft\Windows\LfSvc\Geofence\S-1-5-18_NonPackagedApp\Geofence.dat

But I have that filter:

Can please anybody help me to get this working?

Regards, Steffen

Hello and welcome to the forum!


Because the backslash is an escape character in regex, you need to double it up when your intent is to match a literal backslash in the path.

Your single slash in front of the d is ok since \d is the escape sequence to match a number. BUT you want to have a plus after that to match one or more numbers instead of just a single number (although it probably still would have worked).

Also, because regex will match substrings by default it is pointless to have .* at the beginning or end of the regex. So taking into account the above suggestions, try this instead:


For this one:


This is not being defined as a regular expression since there aren’t square brackets. For regular (non-regex) pattern matching, I believe Duplicati requires either full path info or wildcards as it doesn’t do substring matching without them.

You can either add wildcard path info like this (would exclude all files named Geofence.dat):


Or do a regex like this:


Hope this helps.

Thank you.

So the double backslash was removed if I past this to the forum. But your are absolut wright I forgot the + after d and now it works fine!

Of course -Geofence.dat is no regular expression but is showing at the GUI as Exclude specific files so I think I can put the file Name only? I have many files like that and so I aways have to put *\ in front of the files?

Regards, Steffen

Oh, maybe I’m wrong about that. I almost always use regex instead of regular filters so I’m not super familiar with them. Maybe give it a try and see if helps though.

You are right again. Filter seems working with *\ in front of the filename.

Do you have a good Regex for Cache folders like MSOCache, GPUCache or only Cache - not handle by the system filter -{CacheFiles}?

Thank you, Steffen

No, I do not… I don’t back up the root of the C:\ drive but instead only my user file areas along with C:\username\AppData\Roaming. I think most cache folders are in C:\username\AppData\Local, or maybe if system level they are in C:\ProgramData.

I use a different tool for doing image-level backups of my system in case of disaster, as Duplicati doesn’t support full operating system restore.

If you are trying to eliminate errors because files are in-use, the other option is to enable the snapshot-policy feature so VSS is used. Open files can be backed up if a snapshot is taken. You do need to run Duplicati with elevated rights in order to use snapshots.

Thank you. Yes Snapshots are a good idea I have already try but I ca not set a option to only snapshot special drives. If I enabled snapshot Duplicati try to snapshot all and I have a shared drive in the backup and this let Duplicati show a error …

So I’m working again with some filters.

Thank you very much!

1 Like