Filesystem filling up during backups

Hi,

I’m backing up 200G and I see my /tmp filesystem filling up and eventually crashes as the system only has 200G allocated. Seems that duplicati is copying the entire backup volume to this directory. I’m backing up to B2 and don’t see any usage during the backup.

I am using encryption as well.

Reading other posts seems there is a upload_volume_size that determines the size of the volume before sending to the cloud storage (if I read the post correctly).

I’m unable to see this configuration item in the settings drop down though.

Appreciate any guidance.

First upload/newbie so apologies if I’m doing something wrong here!

Cheers,
K

Having recreated the b2 bucket, recreated the backup job with 100MB upload volume size to 100mb (although think this was not the issue) - I have started the backup again and now can see /tmp remaining stable (i.e. not increasing in size significantly) but more imporatantly I can see the duplicati files in the B2 bucket.

I suspect there was a comms/config issue somewhere causing the backup to store in tmp until the b2 bucket was available.

anyway will update once the back up finished in case useful for others.

thx
K

Welcome to the forum @Kryten73, and thanks for sharing your experience!

Usually the issue you reported is as you described - a combination of “Upload volume size” (--dblock-size) and --asynchronous-upload-limit bigger than your /tmp available storage. With the default async upload limit of 4 and a dblock size of 100MB you would need at least 400MB (4 x 100MB) of space available in your /tmp folder.

Another solution might have been


--asynchronous-upload-limit
When performing asynchronous uploads, Duplicati will create volumes that can be uploaded. To prevent Duplicati from generating too many volumes, this option limits the number of pending uploads. Set to zero to disable the limit
Default value: “4”


--asynchronous-upload-folder
The pre-generated volumes will be placed into the temporary folder by default, this option can set a different folder for placing the temporary volumes, despite the name, this also works for synchronous runs
Default value: “C:\WINDOWS\TEMP”


--dblock-size
This option can change the maximum size of dblock files. Changing the size can be useful if the backend has a limit on the size of each individual file
Default value: “50mb”

Thanks for the reply Jon - not had time to look into your response in detail but will do. Happy to report all stable now and working well.

Very pleased to have found duplicati.

Hope to configure back at some point!

Thx

1 Like