Feedback from a new user - mainly Windows use

#6

Yes, but thanks to Windows I considered it too hokey to deal with. It either required screwing with the system account (giving it access to the network) or using a dedicated user account (which means if the password ever changes I have to remember to update it in the service too).

As an alternative I started using --run-script-before-required and --run-script-after tasks to map / unmap the a drive letter. Yes - this left passwords in plain text in the script file, but that wasn’t a problem for my environment.

Eventually, I gave up and just switched to SFTP on my server, even though all my backups are local.

1 Like

#7

@ts678 - thanks, but please don’t try and teach me how to do UNC paths on Windows. I have been working in networking since the 1990s. It looks more like this is the issue with running as a service, but the error messages are a little vague.

@JonMikelV The drive mapping is a useful backup as I can still use specific username and password pairs.
This is also an environment I am not too fussed about password visibility. If they can read the password then that means they already have access to the PC.

I have a separate user setup for the backups as I was trying to play a small security game with any LAN based virus aiming to get Duplicati to work with different credentials to the desktop user.

I’m going to go deeper in some experiments and see what I an achieve. I would really like to help here and if I can pull out useful knowledge from my own Windowz background to get this side working I would be more than happy. Many of my target environments are only three PCs in a room where I wanted a buddy\buddy backup chain.

This is also accelerating an alternate solution of my own. I was considering running a home cloud server of my own that I then rent to my clients as “off site backup”. I’m now looking closer at getting that going as is will be more sensible than LAN backup anyway.

0 Likes

#8

My aim is to backup open Outlook mailstores across a network. This is why I am tripping up. (Especially because the first time I did this was from a normal user account… which backed up fine over the network)

The more I think about the limitations of a service to access the network, it is sounding like I really need to setup a whole “MrBackup” admin user from each PC that is going to backup. Or just map\unmap the path during the backup.

Whichever route I go I’ll be back to document the gotchas as the error messages on the set backup path page were misleading me.

0 Likes

#9

It sounds like you’ve got some good plans to work towards. :clap:

I agree there are rough edges with UX and error handling / reporting, but we’re still smoothing out some functional issues related to recent updates so haven’t taken any time to work on improving the “self help” side of things.

But reports like yours can definitely help guide where more polish could be added. :slight_smile:

As for your centralized off-site backup idea, I know many users have used the S3 compatible Minio app for the destination. If you want additional features beyond storage NextCloud / OwnCloud might be worth looking into as well.

0 Likes

#10

@JonMikelV I am also an ex-dev so know all about decent feedback. You guys are caught up in the complex mechanics of making this thing work. So I am taking plenty of notes on what I am seeing to polish the GUI to make it more idiot proof.

Didn’t get much time to look at this today, but did get confirmation as to what happened with the backups. The “Run as a service” option is why the paths had messed up and @ts678 was right in guessing these were being dropped into the Program Files folders.

I will experiment a bit more about how the Service logs on and see if I can get some combination to work.

What would help a lot for the average support guy like me who is too busy to read a manual is some more descriptive error messages.

As I said, I am taking notes so will drop this feedback in a larger complete mass instead of these babbled thoughts.

1 Like

#11

I am hitting a wall here on the LAN backup. I’m stuck in an all Windows environment. Need to run Duplicati “As a service” so it will backup locked files (mailstores). But this means no LAN access.

I tried doing the “map a network drive” method, but that destination can’t be seen by the Duplicati service either.

I was thinking of installing NFS on the destination machine - but am then at a bit of a loss as to how to address that from the Duplicati client.

I seem to have run out of options for “simple LAN backup”. Will try a few more options today and add findings to this thread. Been too long since I messed around with user accounts and rights on Windows.

0 Likes

#12

Giving up on SMB for now. There has to be some simple option for a LAN, but I can’t find it yet.

Have swapped to FTP for now. Am experimenting with FileZilla Server on the destination PC. Changing of port numbers and a user account will help. Only using FTP internal to the LAN with no external access.

Not sure how this affects the backup speed. Initial tests are just plain FTP - the (S) bit will come later.

0 Likes

#13

This needs writing in LARGE letters to stop other Windows users wasting time trying to get backups to work across the LAN.

“Running as a Service” is a natural thing for us Windozers - we need the backup to run when other users are logged in. Or we need to backup a locked file like a mailbox. So Duplicati has to be “run as a service” to allow this to happen, but then we don’t have LAN access…

I am now playing with different options for the server. I know and trust FileZilla Server and have that running happy across the LAN. So I have “Backup to FTP” working. The next question is - do I bother going deeper into SFTP if I am just on the LAN?

In one example I am in a building of six PCs and Sod’s Law says the one with the spare big hard disk in it is Win10 Home. So I need dumb simple software to run on something like that. Hence the FileZilla option.

Anyone know of an SFTP option that can run? (And don’t say “build a linux box” or “use a Pi” as I am trying to do minimal changes to the hardware currently in use. The Pi option is for a different day \ different experiment)

0 Likes

#14

Error Message Feedback
One problem I am having is in understanding the error logs. They are way too verbose for me at times. Especially when sometimes the “error” is not really an error.

Example: Duplicati is “Running as a service” and I want to uninstall it.

I go to an Admin command prompt.
Swap to the Duplicati folder.
I stop and delete the service, and then uninstall

sc stop duplicati
sc delete duplicati
Duplicati.WindowsService.exe uninstall

This gives an error. The error is that the service has already been deleted. So it is not really an error…

I also saw a similar set of non-errors when I installed the service twice on top of itself. I think in that case it told me the error was “Service already running” but in that situation I could not work out if this was a problem or not.

Missing Visual Studio 2018 package
Other confused errors appeared when I was on a fresh Win10 x64 PC. I think my first attempt of running as a service spat out errors due to the missing VCDist package… but those messages were a bit too cryptic to make sense of as I was having all kind of other problems that day.

It especially needed the package on an Old WIN10 x86 PC. More errors were triggered on there when I ran the Duplicati Installer before I had run the VC update.

Currently I am learning a lot as I try and set this up in different locations. Some of my feedback is from my errors in understanding how things work. This thread has various mistakes of mine. As I learn more I’ll make the comments in here more focused.

0 Likes

#15

Originally I was disappointed that Duplicati has SFTP but not FTPS listed. But it appears that FTPS is an advanced option for either of the two FTP options. Making it more directly visible as a protocol may help.

FTP over TLS and FTPS using Explicit TLS howto (Server) may help Filezilla users who want to try it out.

For SFTP, various ones are mentioned in the forum. Bitvise has a How-To, but I think some license limits.

While I find home Windows shares to be hard and unpredictable (I wonder if enterprises have it easier?), sometimes I can make them do what I want. For Duplicati, give UI a UNC path, Username, and Password. Duplicati for this test is running as a Windows Service as default SYSTEM user. This backup worked OK.

Microsoft says that Drive letters are not global to the system, and Network Neighborhood is fading away, therefore Duplicati is probably limited in what it can do. It looks like it adds shares, no NET USE needed.

0 Likes

Choosing different drive letter
#16

I’m a Crashplan refugee as well and I would just to like to say that I’ve been using Windows shares as backup destinations for a long time without issue. I found it more reliable than SFTP when I started using Duplicati almost a year ago. Never had any reason to change it. I am backing up a small tax office 4 states away from me (mom’s business! :slight_smile: ), using Duplicati on all workstations backing up to the the main workstation through Windows shares. These are all running as a service so I can use VSS to capture Quickbooks and Outlook files, no problem. I set it up this way to facilitate fast local restores when needed, at the cost of using up some local side storage. Using a local destination also ensures the backup is never missed due to their internet going out. I then use a different open source product called Syncthing to synchronize the Duplicati folder over the internet to my server in the basement. I don’t really trust SFTP since I cannot predict the reliability of their internet 100%. Syncthing is persistent and will immediately continue synchronizing if there are any network problems and has worked wonderfully for my purposes. I’ve been keeping a daily backup since September, the first workstation I set up over there has 317 versions available taking up about 50 GB with their offsite backup many states away, synchronized within a few minutes of any files being written.

1 Like

#17

Thanks for the input. I use Syncything as well (so far without issues) but would suggest you do some small test restores from BOTH locations.

At 50G copying out all locally to do a small restore would take a while, so make sure you know what’s involved OR have a method (FTP?) for Duplicati to directly access the Syncthing destination. (If FTP isn’t an option, consider thr ZeroTier VPN.)

@BatterPudding, keep the comments coming! Many of them (like errors) I agree with but time just hasn’t shown up to allow updating it.

I may try and look at a #howto for LAN backups with Duplicati Windows service to help ease others following in your footsteps. :slight_smile:

Oh, and if you want to contribute then feel free to make your own #howto on what you did to get FileZilla FTP Server running on Windows 10 Home. :wink:

0 Likes

#18

Oh I’ve done all kinds of testing to makes sure this works for me. I did a disaster recovery scenario where I lost complete access from the backup source 4 states away. On my server, I simply added a new backup with the Syncthing folder (which is already local and 100% synchronized) as the destination for the backup, repaired the DB and I was back in business, ready to restore any and all versions. Bonus: The backup source has “Send Only” enabled, so when I re-enabled the synchronization, the original backup source is safe from changes on my end. I have also done at least a few actually-needed restores for the users on their end with no problems.

0 Likes

#19

I had the same issue but am now running Duplicati as a service using VSS on one of the Win 10 home systems here and backing up directly to a SMB share sitting on a ‘Open Media Vault’ NAS.
The path I use is \\ComputerName-or-IP.address\share-name/folder/folder

0 Likes

#20

Thanks All :slight_smile:

@TPSMono and @Daine I wonder what it is that I am missing with my LAN setup then. Which user does your service login as? I just can’t get mine to behave.

I have noticed your funky path there. Maybe that is part of it for me.

I’ve been dealing with Windoze network shares for years, so I know that side is setup to work correctly. I can test from the PC fine. It is just that last little link across from Duplicati as a Service. Which user is it supposed to login as? I thought I had tried login as SYSTEM as noted by @ts678

@JonMikelV The FTP Server as destination method was comically simple to setup. Though I then proceeded to break it by trying FTPS and TLS login. @ts678 has saved me some testing time there by pointing out no FTPS in Duplicati. I did look at SFTP but the Bitvise is a “non-commercial use” application, so not an option for me.

I will be taking my test version of the FTP Server solution over to a client shortly. I’ll take some screenshots during setup for that one. As this is within the LAN then plain FTP should be fine. The FTP server will not have an external WAN port.

Both the “Backup to Windows LAN when running as a Service” and “Backup to FTP Server” are due to get mini HOWTOs written up by me. I want to feed back in what I have learnt.

0 Likes

#21

I was claiming (possibly incorrectly) that the FTPS in Duplicati exists but isn’t listed specifically as FTPS name. Perhaps you can resume trying to get it to work, or possibly there’s more help on it in the forum or on GitHub.

FTPS (also known as FTPES, FTP-SSL, and FTP Secure) is an extension to the commonly used File Transfer Protocol (FTP) that adds support for the Transport Layer Security (TLS) and, formerly, the Secure Sockets Layer (SSL, which is now prohibited by RFC7568) cryptographic protocols. 

is from the link I cited, and Duplicati’s placement of encryption under FTP fits technically but is harder to spot.

Filezilla is, I think, quite good from a licensing view. Many of the fancy SFTP servers have license restrictions.

If you’re on a recent enough Windows 10, there is a beta version of OpenSSH-based client and server inside. This is a Windows port, but if you’re willing to run Windows Subsystem for Linux (WSL), more options open…

I’d note that the Windows port of openssh had some problems but fix might be known. No news from @DL38.

0 Likes

#22

I am starting to wonder if much of my problems are down to the Visual Studio package not installing properly.

Just been on site with that client, in between other tasks I did another test. Working from a different PC, this time doing a big backup to FTP.

Win10 Pro (x86) PC, Installed Duplicati as a service, set “snapshot-policy = on”, left Thunderbird Mail open, kicked off a big backup…

And I found that Alpha.VSSx86.dll error popped up.

=> Could not load file or assembly ‘AlphaVSS.x86.dll’ or one of its dependencies. The specified module could not be found., Failed to process path: C:\Users\Martyn\AppData\Roaming\Thunderbird\Profiles\0j8qpsn9.default\parent.lock => The process cannot access the file ‘C:\Users\Martyn\AppData\Roaming\Thunderbird\Profiles\0j8qpsn9.default\parent.lock’ because it is being used by another process.

And from reading elsewhere this says I need to install the VisualStudio update. Which is odd, as it is already on here as I remember running it. Should I now reinstall Duplicati on this PC? Would the lack of the VS pack mean the installer failed? Or the service install may have failed?

On a separate test… LAN backup seems to want to work this time. Am using the IP v4 Address instead of the computer name. Which makes some sense as the Win10 PCs in the network mean more IP v6 running around the LAN.

\\192.168.1.203\stuff/martyn and giving it the username\password seemed to work this time. Or at least it passed the test. Just failed to backup due to that AlphaVSS.x86.dll again. Puzzling…

0 Likes

#23

@ts678 the vagueness in your comments about FTPS implies you haven’t used it yourself. So I’ll be skipping that experiment for now as I have enough testing puzzles I am working through. :smiley:

FileZilla is an OpenSource project. Brilliant FTP Client, and I have used the server a few times before.

Has been comically simple to setup a Server, add a user, tweak some security. Looks like a simple answer for LAN backups when other options fail. It is also handy as it is an “any OS” solution too.

I will be making a proper HOWTO Backup To FileZilla FTP Server in next few days. Find it so much easier to use than other FTP Servers I’ve previously configured. But then that is the beauty of open source collaborations - the best of the ideas get boiled into the file product without ID-10T users in Marketing getting in the way.

0 Likes

#24

OKAY… here is Feedback from using Duplicati on a 32-bit Win10 PC

This PC is an older messier one. It auto-upgraded from Win7.

It is a 32-bit OS installation.

Last week I ran the Duplicati installer on here. Then ran the commands for converting to a service.

FEEDBACK NOTE ONE:

Please throttle back on some of the splurge of debugging info hitting the screen. So much went up on the screen as the service was starting up that I think I missed all the errors caused by not having the VisualStudio package installed.

With that debugging info it is too easy to miss real errors. The errors need to SCREAM OUT so attention is paid to them.

Subsequent tests this PC were failing the backup with the AlphaVSS.x86.dll error as noted in an above post.

I swapped back to a command prompt.

duplicati.windowsserver /uninstall

Note This caused a pop-up error message about not being able to stop duplicati service. So I manually stopped and removed the service

sc stop duplicati
sc delete duplicati
duplicati.windowsserver /uninstall

Still got the same pop-up error box. No other error text splurge to the command prompt though.

I then fully uninstalled Duplicati and rebooted.

Ran the VisualStudio update again. Rebooted. Ran the Duplicati installer. Installed as a service - no errors.

Ran my test backups again - and all is now happy!! No errors on the locked files.

Suggestion:

Maybe find a better test for the lack of the VisualStudio update? Maybe catch the AlphaVSS.x86 error and tell the user to go install the VS package and reinstall everything properly?

Or maybe during the initial run of duplicati.windowsserver slam a message box up in the user’s face when the AlphaVSS.x86 error kicks in.

I think this could well be the heart of my issues.

1 Like

#25

Swapping Destination Test

Right - I am now going to be a right awkward sod to my little x86 test PC… I’m going to swap that Full Backup from an FTP target to a SMB target in the same folder.

So, if I understand this right, Duplicati should just handle this without a hiccup. And as I had just run the backup via FTP, swapping to SMB should mean nothing changes. I am expecting a speedy backup as nothing needs to be updated.

Hehe… I am cruel. (I’ll update this post soon with test result)

Edit: Clever little Duplicati. The initial backup was 50GB using FTP across the LAN. I then edited just the destination and swapped to SMB across the same LAN to the exact same folder. And Duplicati sped through the file check and was more than happy.

0 Likes