Fedora 31 and duplicati?

Tried upgrading and it errors out… and when I’ve got a VM set up with Fedora 31 installed and try to install duplicati, I get:

 Problem: conflicting requests
  - nothing provides mono(appindicator-sharp) needed by duplicati-

So is it known that duplicati doesn’t work with Fedora 31? Or at least with the version of mono provided there?

Apparently it’s a bug in libappindicator in F31 1768157 – libappindicator-sharp-12.10.0-25.fc31 no longer provides mono(appindicator-sharp) .

I got it working by installing all other dependencies (also making sure that libappindicator-sharp is installed) and then forcing the install with “rpm -i --nodeps …”

I don’t know if Fedora 31 has been discussed before, but other Linux-based operating systems have had similar issues. Sometimes the mono version included in the standard repository is just too old.

Glad you were able to get it to work!

Duplicati fails to install on Fedora 31 #3974 was the same problem, and cites a Fedora packaging issue that I suspect was filed specifically from that Duplicati issue. I guess we’ll see what Fedora has to say…

Regardless, all of the application indicator code is getting old and distros will eventually force a change.

Duplicati fails to install at Centos 8 #3950 has more about this. Newer Red Hat & Fedora are a problem.

Damn, I was almost ready to upgrade to F31 as I just saw that the final piece of my plan, MariaDB, now has a repo for updates, so I’ll need to check into this Mono issue more closely. It was bad enough converting my two Docker containers to Podman.

Still seems to be a problem, but I’ve upgraded to Fedora 31 now and I’m trying to get Duplicati installed.

I tried some instructions I got from Redhat back in January, and rebuilt the latest canary RPM with the following changes:

This is a two minute fix to the spec file and it has been fixed in the rpm for F32 and F31 Modular, unfortunately nothing in F31 proper. If you remove Duplicati, do your upgrade, and rebuild the rpm with rpmrebuild it should work fine. (https://linuxconfig.org/how-to-modify-an-rpm-package-using-rpmrebuild is a good starting place)

Provides needs added:
mono(appindicator-sharp) =
mono(policy.0.0.appindicator-sharp) =
mono(policy.0.1.appindicator-sharp) =

Requires needs added:
mono(gdk-sharp) =
mono(glib-sharp) =
mono(gtk-sharp) =
mono(mscorlib) =

I then installed the new RPM and it was successful, and it installed the dependencies without errors. However the Duplicati service itself won’t start:

Feb 23 16:44:17 MAGGIE systemd[1]: Stopped Duplicati Backup software.
Feb 23 16:44:17 MAGGIE systemd[1]: Started Duplicati Backup software.
Feb 23 16:44:18 MAGGIE mono[131293]: A serious error occurred in Duplicati: System.PlatformNotSupportedException: Operation is not supported on this platform.
Feb 23 16:44:18 MAGGIE mono[131293]:   at Duplicati.Server.Database.ServerSettings.get_ServerSSLCertificate () [0x00115] in <e69e4c0173384a62bf88cae30cea7f3d>:0
Feb 23 16:44:18 MAGGIE mono[131293]:   at Duplicati.Server.WebServer.Server..ctor (System.Collections.Generic.IDictionary`2[TKey,TValue] options) [0x002a4] in <e69e4c0173384a62bf88cae30cea7f3d>:0
Feb 23 16:44:18 MAGGIE mono[131293]:   at Duplicati.Server.Program.StartWebServer (System.Collections.Generic.Dictionary`2[TKey,TValue] commandlineOptions) [0x00000] in <e69e4c0173384a62bf88cae30cea7>
Feb 23 16:44:18 MAGGIE mono[131293]:   at Duplicati.Server.Program.RealMain (System.String[] _args) [0x00227] in <e69e4c0173384a62bf88cae30cea7f3d>:0
Feb 23 16:44:18 MAGGIE systemd[1]: duplicati.service: Main process exited, code=exited, status=100/n/a
Feb 23 16:44:18 MAGGIE systemd[1]: duplicati.service: Failed with result 'exit-code'.
Feb 23 16:44:24 MAGGIE systemd[1]: Stopped Duplicati Backup software.

Any suggestions or a better way to install it?

I’ve discovered that the service settings to enable the use of an SSL certificate is the cause, when I remove them I am able to access the GUI. The service actually started before, it was the connection via HTTPS that then killed the service, but would then repeatedly fail until stopped.

I did find an old Mono thread that hinted at SSL issues but I need to look further to see if I can fix it.

1 Like