Failure "Gateway timeout" when fetching file information

Hi guys,

I have a backup-job 595693 files (which is not ideal, I know). When trying to restore, fetching the file information results in a gateway timeout. My installation is new, I have only a few jobs and even less versions. I’m using Duplicati version

Is there any way to increase timeout? (tried with advanced option “http timeout”, but I believe that’s not relevant here). This is my configuration.

Any help would be very appreciated :slight_smile:

CreatedByVersion “”
ID 4
0 “ID=16”
Time “2020-11-22T22:00:00Z”
Repeat “1D”
LastRun “2020-11-21T22:00:00Z”
Rule “AllowedWeekDays=Monday,Tuesday,Wednesday,Thursday,Friday,Saturday,Sunday”
0 “mon”
1 “tue”
2 “wed”
3 “thu”
4 “fri”
5 “sat”
6 “sun”
ID “16”
Name “Omgevingsdienst Noordzeekanaalgebied testomgeving”
Description “”
TargetURL “file:///backup/odnzkg/”
DBPath “/root/.config/Duplicati/EBMBXVPPZS.sqlite”
0 “/acceptatie/odnzkg/”
Filter “”
Name “encryption-module”
Value “aes”
Argument null
Filter “”
Name “compression-module”
Value “zip”
Argument null
Filter “”
Name “dblock-size”
Value “50mb”
Argument null
Filter “”
Name “keep-time”
Value “10D”
Argument null
LastBackupDate “20201121T220000Z”
BackupListCount “5”
TotalQuotaSpace “214639316992”
FreeQuotaSpace “209588420608”
AssignedQuotaSpace “-1”
TargetFilesSize “1434514163”
TargetFilesCount “63”
TargetSizeString “1.34 GB”
SourceFilesSize “4480190766”
SourceFilesCount “595693”
SourceSizeString “4.17 GB”
LastBackupStarted “20201121T220000Z”
LastBackupFinished “20201121T232422Z”
LastBackupDuration “01:24:22.0205670”
LastCompactDuration “00:00:32.6438760”
LastCompactStarted “20201121T232346Z”
LastCompactFinished “20201121T232419Z”
IsTemporary false
/acceptatie/odnzkg/ “odnzkg”

Does this refer to using the Restore files option of a healthy backup job not showing the tree view?
Where and how exactly do you see “Gateway timeout”? Is it done like a Duplicati error in a popup?
Screenshot might help. I can’t tell if this is a remote error passed through, local server, or browser.

There doesn’t appear to be such an error message in the Duplicati server. Your backup is to files?
That would eliminate that as something that would give what sounds like an HTTP error message.
What browser is this? Is it on the system or going across a network that might introduce an error?


What OS is this? Forward slashes suggest mono used, so does mono --version say at least 5?


Thanks for you reply! I provided way too little information, sorry.

We’re using Centos 7. The backup is healty, see:

I want to restore the files from one version via the option “Restore files”.

This takes a while saying “Fetching path information” before the following error occurs:

The problem also exists when we’ve only 1 version of the backup.

Thanks in advance!!

I’ve exactly the same problem.
My backups are getting stored on an FTP-server. Backup went fine, but restore produces the same error.
My backup has 1.152.289 files and a size of 150GB.
I’m running Duplicati as a docker container.
I’m happy to assist you with supporting logs and doing tests.

Cheers Jochen

I switched the docker image from duplicati/duplicati:latest to duplicati/duplicati:canary and the issue seams to be fixed with it.