Failed to process file (not found), but it is there


I am using Duplicati on Qnap and sync it to Jottacloud.
I am doing several backup jobs, but one throws always an error:

2022-02-08 11:32:50 +01 - [Error-Duplicati.Library.Main.Operation.TestHandler-FailedToProcessFile]: Failed to process file

If I check the full log I see this:

    "Verifications": [
        "Key": "",
        "Value": [
            "Key": "Error",
            "Value": "One or more errors occurred. (The remote server returned an error: (404) Not Found.)"

Now I check the directory on Jottcloud and I see that the file is there.

I tried repair database, but the error still comes up.

What can I do to get rid of this error.

BTW: The backup seems fine otherwise.

There was a similar thread in the past and one of the posters mentioned the Jottacloud CLI tool couldn’t download the file either. Can you try that? Sounds like it may be something Jottacloud needs to investigate.

So I tried to download the file via the webfrontend and it was only about half the size it should have been.
Just for fun I opened the file in Notepad++ and it was a 404-html site. So I guess the file is gone for whatever reason but still visible.
If I rename/delete the file, is duplicati able to recreate it through a repair command?

Yes, if your local database is in tact then dindex files can be rebuilt/reuploaded. Only click the Database → Repair option. (Don’t use Database → Recreate in this case because it will delete your local database.)

1 Like

Just as a follow up:
I deleted the remote dindex file and repaired the database.
The next backup was successful without any errors.

1 Like