Failed to process file ... due to HashMismatchException error

Suddenly one of my backups to google drive started to fail due to the error in the title, as logged below:

2019-06-18 09:49:05 +02 - [Error-Duplicati.Library.Main.Operation.TestHandler-FailedToProcessFile]: Failed to process file
Duplicati.Library.Main.BackendManager+HashMismatchException: Mancata corrispondenza hash nel file "C:\Users\Myname\AppData\Local\Temp\dup-b86434d2-ed85-4889-b962-9b56e547e4c2", hash registrato: +KAA4zvZPCQcZkQZaP7ylOeMOwZ/5+cV06eBYjn+P7U=, hash effettivo x63Iat6swBjAH8ly0Pkd/KsbYYEQsEalzB/03xkpcks=
   in Duplicati.Library.Main.BackendManager.GetForTesting(String remotename, Int64 size, String hash)
   in Duplicati.Library.Main.Operation.TestHandler.DoRun(Int64 samples, LocalTestDatabase db, BackendManager backend)

I tried to follow some hints, the last one suggesting to delete the duplicati-*.dlist.aes file and then repair the database, but the error reappears at the next backup.

Since the thread is more than a year old, I’ve opened a new one (I hope to have made the right choice).

Set a bandwith limit is a prior post from you wanting one. Did you limit at any time of backup history? If so:

Upload throttle corrupts backup, especially OneDrive. Analyzed, with code proposed. #3787

Google Drive was not tried by me because the fixed-and-tested fix is so simple it seemed easier to just do however (to my dismay) nobody has shown interest in the issue. Meanwhile I’m unsure how common it is.

I’m not certain this is what you hit. Your failure is seemingly on the download verification of a sample set of remote volumes done after backup itself completes. Is that when you see it? Then the question is whether corruption took place on upload, download, or (seems unlikely) at Google. Viewing About --> Show log --> Live --> Retry should let you see the remote filename that became the Temp file with an unexpected hash.