Failed to process file (dlist, dindex, dblock)


I’m suffering currently under the following problem after each backup:

* 2019-09-23 22:57:40 +02 - [Error-Duplicati.Library.Main.Operation.TestHandler-RemoteFileProcessingFailed]: Failed to process file
* 2019-09-23 22:58:20 +02 - [Error-Duplicati.Library.Main.Operation.TestHandler-RemoteFileProcessingFailed]: Failed to process file
* 2019-09-23 22:59:01 +02 - [Error-Duplicati.Library.Main.Operation.TestHandler-RemoteFileProcessingFailed]: Failed to process file

As a backup destination I’m using AWS S3 Glacier space. I already completely whipped the whole bucket and started from scratch but the error is coming back. Also I’ve tried it with the versions 2019-07-14 and 2019-09-20 without a change here.
Currently I don’t really know what I could do here. Also I’ve tried a repair which leads to the exact same error.

Could someone give me a tip what I could do here?

I could be wrong, but I believe with archive storage tiers (like Glacier) you need to disable the automatic testing operation.

Set --backup-test-samples to zero to disable the feature.

You also may need to set --no-auto-compact to true.

Before taking my advice please search the forum for “Glacier” and read posts that have been made before. Personally I would use a competing cloud storage product like Wasabi or B2. They are hot storage but priced about the same as AWS Glacier. You avoid all these issues. :slight_smile:

Good luck

Hi, thanks for the tip! I had to whipe the whole bucket again but afterwards the backups ran without an error