"Failed to get nonce: Too many active login attempts" after setting User Interface password

Reviewing Duplicati as a replacement for Crashplan. So far so good, however I’ve locked myself out of the web interface by setting a password on the Settings page.

When I open the web interface I’m prompted to enter the password but then I get an error saying:

Failed to get nonce: Too many active login attempts

Any suggestions as to how I can resolve this?

Okay I just rebooted (I’m using Mac OS, by the way) and now all my config seems to have been lost :neutral_face:

I can, however, see all my config in the SQLite database when I run:

sqlite3 ~/.config/Duplicati/Duplicati-server.sqlite '.dump'


Weird; I quit and restarted Duplicati from the menu item and it’s sorted itself out. My config has returned and when I log out of the web console I can log back in okay without the error.


I had the same problem, it helped to close the application in the tray and launch it again

Watch what port is behind used in your GUI.

It sound like you may have a service server running (likely at port 8200) and also the tray icon server (likely at port 8300).

Each server has its own config so it can seem like all your settings have been lost if you connect to “the wrong” server port.

Yes, you’re exactly right, I have a mono-sgen process running as root on 8200 and another running as my user on port 8300.

Quitting the menu icon closes the 8300 process; the 8200 one is the one without any config.

Cool! I think I’ll get that printed on a t-shirt. (Oh, wait - then somebody else would have to wear it…)

If you want your tray icon back, try running it with the --no-hosted-server parameter which should tell it to find any existing servers (in this case the daemon/service) instead of starting it’s own.