Failed to connect: The authorization header is malformed; the Credential is mal-formed; expecting "<YOUR-AKID>/YYYYMMDD/REGION/SERVICE/aws4_request"

Hi, I’m new to the Forum
I’m trying to set up Duplicati to back up to AWS GLACIAR.

When I test the connection, in the configuration screen, it returns the error:
Failed to connect: The authorization header is malformed; the Credential is mal-formed; expecting “/YYYYMMDD/REGION/SERVICE/aws4_request”.

I appreciate the help


What you have in the AWS access ID field is wrong. You need to create an Access Key in the AWS console, if you don’t already have one. (I would strongly recommend creating a separate user in IAM just for backups, and grant it access only to the bucket you are using for backups.)

The AWS access ID is a string of letters and numbers like this: AVIN3810NL4NRXQRQCYQ
And the access key looks something like this: LiQ8n3f7zPqskcfzbUL/LoX2fA8hnzdfV2s4tETP

Also the name of your bucket is almost certainly not “backup” as the names must be globally unique. Did you already create the bucket in the AWS console?

Finally, I recommend not using archive tiers of storage like Glacier. By default Duplicati wants to be able to easily read your backup data for purposes of testing archive integrity, pruning data, compacting volumes, etc. Cold storage like Glacier does not allow immediate access so these operations will fail. If you really want to use it, you need to disable a few Duplicati options like version pruning, compaction, and archive testing.

Hey friend
I get it now I’ve changed.
I want to store on S3 and updated the settings.

Now DUPLICATE is reporting another error.

User: arn:aws:iam::951653885014:user/bkp-hml is not authorized to perform: iam:GetUser on resource: user bkp-hml

For testing, I gave full access on S3 to the bkp-hml user.


thanks for the help

Strange, it shouldn’t need the “GetUser” privilege. I searched the forum and found some other threads where people discuss. One person said the error only came up when doing a connection test. If you save your backup job and run it, it worked as expected.

I suggest you change your Folder path from “\” to something else. I recommend you set it to the name of your computer and/or backup job. This way you can store other backup jobs or other computers’ backups in the same bucket. (Each backup job must be stored in a unique folder in the bucket.)

Also, you should use forward slashes, not back slashes.

Hey friend

   It worked out. I made Backup works on S3. It was like you said, it failed in the test but it works in production.