Failed to connect: No site ID was provided; Sharepoint v2

I am trying to set up my Nonprofit Office 365 with Duplicati in OMV where backup from my Odroid goes to Sharepoint. At first, I chose Sharepoint (not v2) and entered my credentials and the site and everything, and the test connection went fine. But there were errors when backing up. Someone in a forum suggested migrating to Sharepoint v2. But I can’t get that to work either. There is a bug where my old username and password are in the destination url, so I copied it, edited out the username and password (and left the oauth) and imported it back in. I’m still getting “Failed to connect: No site ID was provided.” I tried deleting the whole backup and starting over, but no dice.

In “Destination path,” I have tried as well as and and and just /test/ and /test and test. Nothing I put in there will work!

Welcome to the forum @threehappypenguins

Perhaps someone with expertise in this area will show up, but meanwhile I’ll point to some resources.

Changing backend type leaves invalid backend options #3082

Microsoft SharePoint v2 (Microsoft Graph API)

--site-id (String) ID of the SharePoint site to store data in. This parameter is required when using the relative document library path (without specifying the SharePoint site’s web address). This ID can be looked up by querying in the Microsoft Graph Explorer. When the SharePoint site’s full web address is provided, it is looked up automatically.

No backup without “–no-backend-verification=true”

This was helpfull to find the “site-ID”

Issue using Onedrive for Business

No site ID was provided while using Sharepoint V2 #3948

Thank you!!! So to summarize:

In the top of the Graph Explorer, where it says “Get” and “Run Query,” I put something like$select=id

And below in the “response preview,” I copied what was in ID. So for example, I saw something like:,11111111-1111-1111-1111-111111111111,11111111-1111-1111-1111-111111111111

Then in Duplicati, for Destination path, I just put a name for a folder that I want all my backup to go into, and added my AuthID. Under Advanced Options, I chose site-id, and pasted the site ID that I had copied from the Graph Explorer.

I did a test connection, and it worked perfectly!

1 Like

Hi, I’m having the same problem, but I don’t quite get how to use the microsoft graph explorer.
in my case, the sharepoint site is (my onedrive storage root).
Now do I have to put into graph explorer?