Failed to connect: Failed to authorize using the OAuth service

Hi, I have been having an issue with backing up to Google Drive, I get this error.

Failed to connect: Failed to authorize using the OAuth service: Error: NameResolutionFailure. If the problem persists, try generating a new authid token from: Duplicati OAuth Handler

It was running for about a year before this issue showed up and hasn’t worked now for about 2 months.
The changes that has happened is I have changed address but I don’t think this would matter.
I moved the location on my server where the Docker containers are stored. This could be the issue?
I have tried rebuilding the container but still the same problem, tried the suggestion of generating a new authid token. Im about to build another container to check if there is an issue there.
I have read it may have something to do with DNS, I can ping Google drive from the host machine no problem but not sure how to try ping from within the container as it says ping is not known.

Does anyone have any ideas?
Thanks in advance

Welcome to the forum @drwhowhogrub

If you watch About → Show log → Live → Information while running backup, does it end like the below?

I’m not sure why your message is a little different (specifically, by not saying that DNS cannot resolve).
Above test was done with my network disconnected. Before Duplicati can go to Google Drive, it needs authentication information which it gets using AuthID from a server. See How we get along with OAuth.

Containers typically lack good debugging tools. I wonder if testing from the host would help debug this?
I think you need to be able to go to using either IPv4 or IPv6. and similar services can give host’s addresses, but container may differ.

Does the Docker have nslookup or dig or host to try DNS? If need be, genuine bash can awkwardly try:

If host is a valid hostname or Internet address, and port is an integer port number or service name, bash attempts to open a TCP connection to the corresponding socket.

Here is the log, I get basically the same error message as you.
I have applied a new authid tokens several times and still get the same message. I can definitely get a new token.

I have also spun up a new container fresh install and get the same problem.

I can ping “” from the host machine (OpenMediaVault) I can also ping that address from another container running syncthing.

I tried that but just got “no file or directory”