Fail: Detected non-empty blocksets with no associated blocks!

Hi
My backup job is failing , I get this message:
Detected non-empty blocksets with no associated blocks!

I tried verify and got the same error.
I tried repair and got the same error. I have not tried delete repair.

How can I fix this?

Thanks
David

There is no sure-fire fix procedure that I know of, but you will be able to do a safe trial by doing a manual rename of database (basically like a delete where you can undelete it later if you want to), then a Repair.

If you like, before that, you can run a database bug report to post by link. Maybe it will shed some light…

Posting your last job logs before backup broke would be an easier way for people to maybe spot a clue.

If you personally have any clues on how it came to break, please supply. This would be helpful to the fix.

Hi
I ran out of space on my OneDrive account, after that the backups all started to fail with these errors.

I cleared some space and also changed the retention policy to reduce the space being used. I then ran a database rebuild. That seemed to fix some of the backups but not all.

I’m now getting: Failed: Unexpected difference in fileset version 9: 30/11/2020 17:30:00 (database id: 66), found 1527981 entries, but expected 1527983

I tried a verify and that gave the same error. I’m running a repair in the hope that will fix my problem.

Thanks for the clue on how this might have started. Are there any logs left? DB Recreate would wipe the previous job logs, but you might still have server logs in Home --> About --> Show log from out-of-space.

Unfortunately there are no logs reflecting the OneDrive full problem only subsequent logs filing for other reasons alread described.