Exclusion of one of the sources, followed by cleaning the archive.

Hello friends!
I decided to reduce the size of the backups by excluding one of the directories in the “Data for backup” window (step # 3). Question: how now to delete this data from all previous copies created by duplicati?

Hello and welcome!

You can do this with the PURGE command.

Say you want to remove C:\Folder1 from all your previous backup versions. You would run purge with the following option:


You want to be very careful with this option. I’d recommend doing it with a dry run first on a single backup version:

--dry-run --version=10

If the dry-run looks good do it again without the dry-run flag. If version 10 then looks correct, you could take off the version flag to have the purge happen on all versions.

Thanks for the answer!

How can I believe this version later?

Do you mean how can you verify? After purging a folder from a specific backup version, you can go to restore and select that version to see what files it shows. The purged folder should be missing.

I am doing something wrong :frowning:
After entering the encryption password, the system reports that the database was not found, and the truth is, in the settings, the database is located in a different location.


If you normally use the Web GUI for backups, then I recommend doing the PURGE command from the Web UI as well. It keeps things simpler because it will fill in a lot of the necessary info for you.

On the main Web UI page, click on your backup job to expand the options. Then click the blue “Commandline …” link. Change the dropdown to “purge” and clear the contents of the Command line arguments box and add what we discussed above. Here’s an example:


Also – very important – look through the Advanced options below and REMOVE any include/excludes you may have there.

Once you’re satisfied, click the blue “Run Purge now” button at the bottom.

Thank you.
I tried it. Only for me all the backup parameters were not in the upper “Target URL” window, as in your screenshot, but in the lower, third “Advanced options” window - I left it there …
I started it. The system said that the server was stopped, agreed to start it and something started (until I understand - either a scheduled backup, or a cleanup of the backup). We wait…

Выполнение записи командной строки

Предоставленный параметр --dry-run не поддерживается и будет проигнорирован
Listing remote folder …

ErrorID: PurgeWouldRemoveEntireFileset
Refusing to purge 147956 files from fileset with ID 205, as that would remove the entire fileset.
To delete a fileset, use the “delete” command.
Return code: 100

Is there anything else in the backup set? Either there isn’t, or maybe you have some other --include or --exclude specifications in the “Advanced options” box (I can’t see the whole thing in your screen shot). If you have --include or --exclude down there, you should remove them when running PURGE.

I removed everything unnecessary, the result of the work has changed, but still I’m doing something wrong. Or not expecting anything. I want the entire D: ! Acronis Copy Server \ directory to be deleted from me, with all its content, but this does not happen. The screenshot shows that the content remained in place :frowning:

Remember that --dry-run doesn’t actually save any changes. It’s just an option to see what might happen. Maybe you should remove it and try again.