Exclude offline files broken with OneDrive?


#1

Excluding “Offline” file attributes didn’t work for me - didn’t make a difference.
Tested on Win10 1803 with duplicati 2.0.3.1_experimental_2018-03-16.


Cloud drive integration (files on-demand)
#2

Thanks for letting us know - what cloud provider(s) (or close to mounting tool) are you working with? It’s possible there’s an issue with specific implementations…

Oh, and there are a few new versions of Duplicati than 2.0.3.1 experimental - is there a reason you’re not moving to one of them?


#3

What do you mean by “what cloud providers”?

I’m using the standard FTP with SSL to backup to a local NAS.
The only “Cloud Drive” is the 2018 OneDrive Client (currently v18.172.0826.0010) syncing Onedrive, OneDrive for Business and Sharepoint Online with “files on demand” being active.

There’s no specific reason for not updating Duplicati.
I would of course update if there is good reason for doing so, e.g. if I may expect to solve the problem.
Otherwise I’m following kind of a “never change a running system” policy if possible.


#4

Perfectly valid reason. :slight_smile:

I asked about the cloud provider because I believe Microsoft “recently” made some changes to how they stub their files. Updates 2.0.3.7, 2.0.3.8, and 2.0.3.10 all have cloud related updates but I think their targeted at destinations not sources, so are likely not ones that would address what you’re seeing.

2.0.3.5 & 2.0.3.6 had (somewhat major) updates to filters that might fix your issue.

I don’t currently use OneDrive (in my sources) but maybe somebody else who does can chime in and let us know how “offline” filters work for them.


#5

While I didn’t move to one of the latest canary builds with my production backup I tried the latest beta 2.0.3.3_beta_2018-04-02 in the meantime.
Used exclude-files-attributes = Offline,SparseFile,ReparsePoint,IntegrityStream
and symlink-policy = ignore

That didn’t make any difference.

OK, no surprise.


#6

Thanks for testing that.

I’ve moved this to its own topic so hopefully others using OneDrive can chime in.

Just to make sure I’ve got this correct, you are trying to exclude cloud hosted files in the OneDrive “folder” be setting the offline (or any other attribute) exclude type, right?


#7

Yes, I want to exclude the offline files - the ones that are visible in explorer but have not been downloaded by OneDrive.


#8

Updated to the most recent beta 2.0.4.5_beta_2018-11-28 and retested.
Parameters have been unchanged:
exclude-files-attributes = Offline,SparseFile,ReparsePoint,IntegrityStream
symlink-policy = ignore

The new version didn’t make any difference.
The errors still apear as before, giving something like this (partially translated from german):

Failed to process path: <my local file path>
System.IO.IOException: Access to cloud file has been denied
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
   at Duplicati.Library.Snapshots.SystemIOWindows.FileOpenRead(String path)
   at Duplicati.Library.Main.Operation.BackupHandler.HandleFilesystemEntry(ISnapshotService snapshot, BackendManager backend, String path, FileAttributes attributes)

Cheers
Klaus


#9

Thanks for testing with the new version - sorry to hear it didn’t resolve the issue.

It’s possible OneDrive has changed how it flags not-yet-download files in a way Duplicati doesn’t understand.

I’m going to ping @Pectojin in case he has any thoughts as I believe he knows more about clot implementations than I do.


#10

I’m afraid I’m fairly unexperienced in Windows file attributes :frowning: