Exclude Directory (FeedbackHub)

I was testing Duplicati on a test System which is part of Windows Insider. For This reason I have the C:\Users\Administrator\Documents\FeedbackHub\ folder with access restrictions. After running the backup (as user Administrator) I got a warning, that files under this folder are not readable:

First I did not notice that you can actually exclude subdirectories in the directory picker, this is why I added a manual filter. I tried multiple combinations, but none worked:

(BTW: Note that the filter field is unecesary short)

Finally, when I discovered that you can exclude by tripple clicking the filter was added:

Exclude File: %MY_DOCUMENTS%\FeedbackHub\

I wonder if the my documents logic should test absolute path in addition, and I wonder if the description “contains” for Exclude Folder/File is correctly described. What am I doing wrong here?

BTW: it also looks like some filters I added changed to different ones (like expressions and regular expressions have been added. The Gui should probably tell me “great we changed it to the following rule”. And mybe even simulate/access the filter to confirm its working?

Welcome to the forum!

What version are you using? The current Beta release (and some previous releases) have a bug in the filter UI builder causing the filters to not work properly.

Some fixes have been applied to newer versions, but so far they are only in the Canary channel.

A workaround is to click the three-dot menu on the right and “Edit as text”. Do NOT switch back to “Edit as list” afterward or the bug will go into effect again.

If you need help building the filters manually in the “Edit as text” view, let me know.

It is version Thanks for the hint with the text view, I have been able to find a few rules with quadrupel-\ at the end (instead of \). However I am not sure if the exclude pattern worked after that. I will test it in the future if it behaves better.

Can you confirm that it should be able to match the pattern no matter if you use the full absolute path or the %-variables in the search list or the pattern list? If yes, the post is probably wron in the UX forum as it is a “normal” bug.