Error on Backup: InvalidManifestException: No manifest file found in volume

I am having a backup job on Windows that backups like 50GB to a filesystem mounted via SMB.

This worked fine so far. After reading this thread:

I have added these parameters to the job:
backup-test-percentage: 100
full-remote-verification: true
no-local-blocks: true

Now, when I run the job, it fails with this error message:

 Errors 2 
2024-06-10 21:25:13 +02 - [Error-Duplicati.Library.Main.Operation.TestHandler-RemoteFileProcessingFailed]: Failed to process file
InvalidManifestException: No manifest file found in volume
2024-06-10 21:35:53 +02 - [Error-Duplicati.Library.Main.Operation.TestHandler-Test results]: Verified 74 remote files with 1 problem(s)

I have no idea what it means or what the problem is. Any hints please?

This error means that somehow the file has a missing component inside, which would usually describe the most important backup properties. I don’t know why it is missing, but since this is an index file, you can try to recreate it.

To do this, rename it to change the duplicati- prefix and then run a repair on the database page. That will try to create a new index. If this were a block file, it would be more concerning.

After the repair works, it should have a new version of the file and you can delete the old one.

I’m a bit curious what’s in the file. Is size 0? If you open it in File Explorer, is it empty? Regardless, it’s odd.
Google search can’t find any other cases of that error message on the web.

The file is existing and is 300 kB in size. But when looking into it with HxD, it turns it is just filled with 0x00, nothing else.
After renaming it and doing a repair, as suggested, the file is recreated with a size of 1 kB and backup is working without errors then.

So, thanks, this solved it. Still, the question is, what happened there? And can it only happen to index files?

I have seen something similar, once. It was a file with the normal size, but all zero bytes. In my case it was a complete dblock volume, but it was while I was terminating the program, so I’m not sure whether that caused it.

Do you have a date when the original file was created?

Yes, creation date is 22-07-2023 03:00.