Error message Disk full


I´m running Duplicat together with OpenMediaVault on Rasperry Pi 3. Everything is upgraded and updated to the latest version.
The originating disk is a usbdrive with 1 Tb space and the destination is Onedrive with 1 Tb space.
When I try to run a backupjob consisting of about 70 Gb this message pops up after a little while:
Disk full. Path /tmp/dup-520950f3-b029-4621-8315-85c86f3ac377.
Does this mean that Duplicati is trying to put something on the flashmemory?
If I run a smaller backupjob for 500 mb it works fine.

TIA Leslie

Hello @leshol and welcome to the forum!

I have not used a setup anything like that, so must guess, but does “flashmemory” refer to /tmp directory? Sometimes Linux systems use tmpfs (RAM) or other special partitionings. What does df /tmp say it’s on?

Whether it’s RAM or a small partition, the message seems to be saying that it filled up. This can happen if production of files goes faster than upload can move them to the destination. –asynchronous-upload-limit provides a way to limit the upload queue. Also be careful not to use a huge –dblock-size if space is limited.

Duplicati is also known to sometimes leave files behind in the /tmp area. You could check for leftover dup*.

Thank you for your speedy reply. I decreased the number of volumes to 2 instead of 4. It didn´t work. Same message “Disk is full etc” A few seconds after this I get another message: “Connection to server is lost! Trying to connect.” That has happened a couple of times before.
How can I check my drives for directorys and files. I tried ls and dir etc at the command line but it doesn´t work. I´m a newbie at Linux so I´m thankful for all the help I can get.


Instead of the df /tmp suggested earlier (and still suggested), you can survey all your drives with just df:

$ df
Filesystem     1K-blocks     Used Available Use% Mounted on
udev              486300        0    486300   0% /dev
tmpfs             101600    11260     90340  12% /run
/dev/sda1       19478204 15471280   2994444  84% /
tmpfs             507988    16820    491168   4% /dev/shm
tmpfs               5120        4      5116   1% /run/lock
tmpfs             507988        0    507988   0% /sys/fs/cgroup
cgmfs                100        0       100   0% /run/cgmanager/fs
tmpfs             101600       24    101576   1% /run/user/1000
tmpfs               1024        0      1024   0% /mnt/ramdisk

If your system has man pages, you can say man df to learn df. If not, your df might work like this or this.
Once you find which area ran out of space, ls and du would be good but basic tools to see what took it.

“Connection to server is lost” can be reported by the Duplicati web UI if it thinks Duplicati has gone away. Running something like ps -eF | grep Duplicati could confirm/deny it. It’s likely being run by mono. Does this Duplicati run in a graphics environment? If so, you might also see its system tray icon go away. What do you have to do to recover from it? Duplicati’s web browser code will automatically keep retrying, however that won’t get anywhere if the server crashed (maybe from space exhaustion) and stayed down.

Hello again

It seems that I have run out of space. What I can understand the tmp directory is located on the flashdrive and is limited to 500 mb. Is there any way to move it to the usb-disk (LaCie)?

Thanks for all your help.


Last login: Tue Jan 8 19:36:47 2019 from

root@raspberrypi:~# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 7498256 1937512 5440628 27% /
devtmpfs 495480 0 495480 0% /dev
tmpfs 500088 8 500080 1% /dev/shm
tmpfs 500088 55128 444960 12% /run
tmpfs 5120 8 5112 1% /run/lock
tmpfs 500088 0 500088 0% /sys/fs/cgroup
tmpfs 500088 500088 0 100% /tmp
/dev/mmcblk0p1 63503 22548 40956 36% /boot
/dev/sda1 960380628 137138172 823226072 15% /srv/dev-disk-by-label-LaCie
folder2ram 500088 19084 481004 4% /var/log
folder2ram 500088 0 500088 0% /var/tmp
folder2ram 500088 452 499636 1% /var/lib/openmediavault/rrd
folder2ram 500088 12 500076 1% /var/spool
folder2ram 500088 15724 484364 4% /var/lib/rrdcached
folder2ram 500088 8 500080 1% /var/lib/monit
folder2ram 500088 0 500088 0% /var/lib/php
folder2ram 500088 4 500084 1% /var/lib/netatalk/CNID
folder2ram 500088 420 499668 1% /var/cache/samba
tmpfs 100016 0 100016 0% /run/user/0

–tempdir or TMPDIR which is mentioned in that section.

@ts678 is correct, but be aware using a USB drive for temp will likely cause backups to take longer.