Error: "Detected non-empty blocksets with no associated blocks!"

#1

I have a 20GB backup set, it finished to backup successfully. Since then, it throws this error: Detected non-empty blocksets with no associated blocks!

Clicking show, shows nothing. It will now longer backup. What to do? Thanks! Running You are currently running Duplicati - 2.0.4.17_canary_2019-04-11 on linux and b2 backblaze.

#2

Run repair, it might fix the issue. It it doesn’t just delete the backup and create new one.

Duplicati is known to corrupt data and mess up backups, and it’s totally normal that you’ll need to reset the backups repeatedly. As well as remember to run full restore tests every now and then, or otherwise things might end up really badly.

#3

Thanks for your answer, I tried repair, delete repair, all options, nothing helps. Is there a backup solution out there that actually works as a backup solution? Seems duplicati is too beta to be relied upon currently, looking forward to the final release !

#4

It’s true that Duplicati is know for this unsolvable problems - but on the other hand - this only stop future backup. With 100% certainty you could restore already backed up files(even if with recovery tool)

So my recommendation is have two Duplicati backup jobs…or use Duplicati and something else… I don’t think that on the market exist comparable SW with better overal reliability.

For “Detected non-empty blocksets with no associated blocks! eror”:
Recreate DB usually works for me, if no, then backup recreate is fastest solution.
You could also try to remove files from last backup run and try recreate after.

#5

No, there are situations where backing up is resumed and everything seems to be working, but restore still fails.

This is just why incremental or especially de-duplicated backup is very dangerous, if the system doesn’t work correctly.

I’m strongly recommending periodic FULL RESTORE testing to be sure ,that restore actually works. I’ve found unfortunately quite of then that it fails, even if everything seems to be working otherwise.

#6

Did you tried Disaster Recovery - Duplicati 2 User's Manual ?
Or did you try restore without local DB?
Problem is likely only in local DB and data should be OK.

#7

No, that’s not the case. Because the only correct way to do restore test is doing it without local database. If you do it with local database, you’re cheating and when you actually need to run the restore, it’s probably that it might fail even if your tests passed.

That’s exactly why I’m warning about reliability of the system, because it’s not as good as it’s supposed to be. And one of the reasons, why I don’t recommend using duplicati as the only backup solution. Always have two parallel independents solutions.

#8

I started getting this error on a brand new backup. The initial full backup went without a hitch. I got an error regarding issues backing up the .sqlite database on the following incramental, so I just excluded that. All backup attempts afterwards has failed with this error.

I first tried a database repair, which had no effect. I followed that up with a delete and rebuild of the database. That’s currently running and has been stuck at 90% for about seven hours. I’m not getting my hopes up that the rebuild will even succeed, let alone it actually resolving the error if it does complete.

I had a backup that was running well for about a year that suddenly broke with this error and the fact that it’s happened again on a brand new backup that was literally set up yesterday is incredibly frustrating.

Edit:
15 hours later and it’s progressed 2%. I could have run three full backups in the amount of time this has run so far. At this point I think I’m just going to cancel and delete and start the backup from scratch. But how do I know I’m not going to just get that error again tomorrow and put me right back where I am now?

1 Like