Error connecting to Dropbox

Based on the first forum report, Dropbox doing their announced change broke new users mid-January.
Unless you wish to do some developer/network level analysis (challenging) you probably need to wait.

If you’re eager to use Dropbox in hope of future fix, you might be able to use a temporary rclone setup.

1 Like

@Hadi_Asgari I have added a fix to the code, but it will be a little while before an updated version is available.

3 Likes

Hi Hadi_Asgari we’re also experiencing the same issue regarding the authentication process & dropbox. Great to hear you’ve worked the code. Any idea as to timescales days, weeks or months?
Thanks

The fix is ready to be deployed, but the code signing certificate has expired, so I need to purchase a new one first. That usually takes a week or so.

1 Like

Any update on this? We were attempting to restore a backup and can’t set up the new system to access our backups.

No update. I am still waiting for verification before I can get a new certificate (it is always a hassle).

I can build an unsigned version and attach here if it helps?

It would be beneficial for us, if you would do that!
:smiley:
Specially if it could be deployed in Docker, somehow!
:sweat_smile:

I have put up a build here:

It is signed with GPG but not Authenticode. If you run it on Windows you can expect it to trigger Antivirus warnings. Other platforms should not give any problems.

Is there a way to utilize it on a previously made Duplicati Docker container?
For example replacing former files on the Container made using the last Duplicati Docker Image, with the new files, on:

/source/hostfiles/var/lib/docker/overlay2/49c6e8495c1685858bf8fc158a9153a564fb1b6bd98f39895df26c8bfe8399a8/diff/app/duplicati

I guess you can just extract the files and mount the /app/duplicati folder?

Otherwise, I have just updated the Docker images, so you should be able to update the image.

I pulled the new Docker Image (duplicati/duplicati:2.0.6.101_canary_2022-03-13), and deployed it on a new container, but the error exists again, while trying to test the connection to Dropbox:

Failed to connect: Non-json response: Error in call to API function "files/list_folder": The given OAuth 2 access token is malformed.

I tried it again today, and here is the new error:

Failed to connect: Failed to authorize using the OAuth service: Forbidden. If the problem persists, try generating a new authid token from: https://duplicati-oauth-handler.appspot.com?type=dropbox

…After I tried more and more, sometimes it returns the above error, and other times, it just stucks on “Testing Connection…”
Even trying to test with “Google Drive”, or “Google Cloud Storage”, has same results, or after a long time it leads to “Connection Failed” message!

Am I doing anything wrong?!..

Finally! I got the a new certificate and released a signed version. Hope this helps, otherwise, DM me.

It sounds like a general connection issue.

I have released a new version that is signed and follows the normal release process. I hope this fixes the issue for you.

Does your Dropbox authid contain a colon character?
(i.e.: 1234:5678)

1 Like

Does your Dropbox authid contain a colon character?
(i.e.: 1234:5678 )

yes, and i’m having the same @Hadi_Asgari issue on latest docker image.

Welcome to the forum @FrancYescO

While no response came here, I asked about success on the GitHub issue, and got:

[Dropbox oauth] expired_access_token error from Dropbox short-lived access tokens #4667

I just installed 2.0.6.102 and was able to successfully run a new dropbox backup!

but I don’t know where that leaves things. Is it possible that this only fails in Docker?
If someone wants to head over to GitHub, maybe you can look for any differences…

Thanks, i was using the latest tag on docker but looks was not updated enought on the official image neither on the linuxserver managed image

i’ve used the canary image tagged and the new oauth token format looks is accepted
duplicati/duplicati:2.0.6.102_canary_2022-04-06 so seems we just need to wait until the latest image get updated

Nice information. It looks like for Duplicati Docker build, latest matches beta, and canary is a Canary which is sort of an unknown – first public view complete with the new code, with anything that got worse. Please report any breakages so that they can hopefully be addressed before the problem affects others.

Settings in Duplicati explains the channels concept, but it doesn’t fit Docker well because the containers typically get replaced with an updated container rather than letting Duplicati’s autoupdater update an old container to a new Duplicati content. If you see an offer for update, try grabbing a new container instead.

Eventually (I hope), there will be another Beta release after Canary proves itself, and settles down some. There is also a need for Duplicati volunteers (who allow Duplicati to exist) for code, test, documentation, forum – and making releases. There is a release manager needed now. Lack of one makes plans vague.

surely i can say is that settings looks are lost and i’ve not found where is the location to persist settings…

i’ve mounted the settings volume in the same /config dir on the container but going to the webui it will ask again for a first config (if is a local machine or a shared one and i want to set the password…)