Error 400 with

I already used Cloudberry backup with openStack account
When I tried to create the same acces with Duplicati I received a error 400
here is the copy of the logs and the screenshot of both settings (of course I put the same tenant name and APIKey in both setting)
Can someone help me ??

Jul 22, 2018 5:50 AM: Request for http://localhost:8200/api/v1/remoteoperation/test gave error
System.Net.WebException: Le serveur distant a retourné une erreur : (400) Demande incorrecte.
à Duplicati.Library.Utility.AsyncHttpRequest.AsyncWrapper.GetResponseOrStream()
à Duplicati.Library.Utility.AsyncHttpRequest.GetResponse()
à Duplicati.Library.JSONWebHelper.GetResponse(AsyncHttpRequest req, Object requestdata)
à Duplicati.Library.JSONWebHelper.ReadJSONResponse[T](AsyncHttpRequest req, Object requestdata)
à Duplicati.Library.Backend.OpenStack.OpenStackStorage.GetAuthResponse()
à Duplicati.Library.Backend.OpenStack.OpenStackStorage.get_SimpleStorageEndPoint()
à Duplicati.Library.Backend.OpenStack.OpenStackStorage.d__35.MoveNext()
à Duplicati.Library.Interface.BackendExtensions.TestList(IBackend backend)
à Duplicati.Server.WebServer.RESTMethods.RemoteOperation.TestConnection(String url, RequestInfo info)
à Duplicati.Server.WebServer.RESTHandler.DoProcess(RequestInfo info, String method, String module, String key)

I need to use Cloud-a with Duplicati

Hi @RobinDel, welcome to the forum!

I haven’t used OpenStack myself so can’t tell if your settings are correct for Duplicati, but it looks like all the OpenStack code has been handled by @kenkendk, @agrajaghh, and one other developer (epol) on GitHub.

Perhaps one of them will have time to take a look at your screenshots.

Is there anyway to reach them ?

They’ve already been “pinged” - if they haven’t replied yet it’s likely because they are busy.

I know for me real life keeps getting in the way of Duplicati work - I suspect it’s the same for them.

It looks like so far this month there have been almost 6,000 uses of OpenStack as a destination so it’s likely either an issue specific to or your configuration. Again, not having used OpenStack myself I can’t really do any testing for you. :frowning:

Hi @RobinDel

Have you contacted CLOUD-A who appear very reachable and have probably connected many applications?

I don’t use or know OpenStack, but I researched some.

The first thing I’m wondering about is if you use their container specific keys feature, done using<container_name> (replace with the name of your container)

in the directions I’ve seen. The syntax you used was different (is the container really called test/v2.0?)

Their container specific keys invention worries me, but I hope it’s transparent to the application.
Bulk Storage Auth for CloudBerry Products

That’s probably about all I can say.

Yes on I created a container named test (all in lower case)
This container works fine with Cloudberry backup (see my first screenshot)

With Duplicati I tried :
and also

In both case I received a error 400…

Any Help ?

Is it possible you authenticated Duplicati with a container specific key that belonged to a different container than your “test” container?

Yes I already tried with 2 différents container : same problem


Unfortunately, I can’t think of any other things to check at the moment. :frowning:
If I do I’ll let you know.